summaryrefslogtreecommitdiff
path: root/tests/Makefile.am
diff options
context:
space:
mode:
authorChun-wei Fan <fanchunwei@src.gnome.org>2014-08-12 11:42:25 +0800
committerChun-wei Fan <fanchunwei@src.gnome.org>2014-08-15 09:43:22 +0800
commit4bfe7f1da88c6bd73cc51666a13840661ab9edb1 (patch)
tree3b1f24dbb162af25cedb12d511fc1929ab74a940 /tests/Makefile.am
parent6fc4a1f9db8a2149d8db55e578895b73af44d930 (diff)
downloadgobject-introspection-4bfe7f1da88c6bd73cc51666a13840661ab9edb1.tar.gz
tests: Add a Header for Symbol Exporting
This adds a header under tests/ that can be included by the various test libraries/sources so that symbols from them can be decorated by a macro, which can then be used to export symbols by using a compiler directive, like the updates to girepository. This header is also installed as the test headers refer to them. https://bugzilla.gnome.org/show_bug.cgi?id=732669
Diffstat (limited to 'tests/Makefile.am')
-rw-r--r--tests/Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/tests/Makefile.am b/tests/Makefile.am
index 26b59108..8bcf74ee 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -14,7 +14,8 @@ tests_DATA = \
everything.c \
everything.h \
gimarshallingtests.c \
- gimarshallingtests.h
+ gimarshallingtests.h \
+ gitestmacros.h
EXTRA_LTLIBRARIES = libeverything-1.0.la libgimarshallingtests-1.0.la
@@ -23,7 +24,8 @@ libgimarshallingtests_1_0_la_SOURCES = gimarshallingtests.c
EXTRA_DIST += \
gimarshallingtests.h \
- gi-tester
+ gi-tester \
+ gitestmacros.h
BUILT_SOURCES += everything.c everything.h