summaryrefslogtreecommitdiff
path: root/tests/invoke/Makefile.am
diff options
context:
space:
mode:
authorTorsten Schönfeld <tsch@src.gnome.org>2006-10-03 14:38:07 +0000
committerTorsten Schönfeld <tsch@src.gnome.org>2006-10-03 14:38:07 +0000
commitcfde98416f0770093be1041ca11f127dd2165846 (patch)
tree45a8d31f4db5abb7cf1991a68a14c8ab9ee370e5 /tests/invoke/Makefile.am
parent81e4d057747574c1c87d4311832f688d0cf31e05 (diff)
downloadgobject-introspection-cfde98416f0770093be1041ca11f127dd2165846.tar.gz
Hush compiler warnings about return values, signedness mismatches, unused
* src/compiler.c, src/generate.c, src/gidlnode.c, src/gidlparser.c, src/ginfo.c, src/girepository.c, tests/invoke/invoke.c, test/invoke/testfns.c: Hush compiler warnings about return values, signedness mismatches, unused variables, and unhandles enum values in switch statements. * tests/invoke/Makefile.am: Don't install the invoke test program. Add -I ../../src to the cflags used for the test functions files.
Diffstat (limited to 'tests/invoke/Makefile.am')
-rw-r--r--tests/invoke/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/invoke/Makefile.am b/tests/invoke/Makefile.am
index 5163ef68..c49643c9 100644
--- a/tests/invoke/Makefile.am
+++ b/tests/invoke/Makefile.am
@@ -1,13 +1,13 @@
## Process this file with automake to produce Makefile.in
-bin_PROGRAMS = invoke
+noinst_PROGRAMS = invoke
noinst_LTLIBRARIES = testfns.la
testfns_la_SOURCES = \
testfns.c \
testfns-metadata.c
-testfns_la_CFLAGS = $(GIREPO_CFLAGS)
+testfns_la_CFLAGS = $(GIREPO_CFLAGS) -I ../../src
testfns_la_LDFLAGS = -module -avoid-version
testfns-metadata.c: testfns.xml