summaryrefslogtreecommitdiff
path: root/tests/offsets/Makefile.am
diff options
context:
space:
mode:
authorEmmanuele Bassi <ebassi@gnome.org>2017-05-04 23:12:45 +0100
committerEmmanuele Bassi <ebassi@gnome.org>2017-05-04 23:12:45 +0100
commit2d7cb109011b694904653eb6969049be36011cf8 (patch)
treedd10b6477768aa289e168360a47a468f438aece2 /tests/offsets/Makefile.am
parentf167c42e4b4789f9a905f5ecbcd74410751909ce (diff)
downloadgobject-introspection-2d7cb109011b694904653eb6969049be36011cf8.tar.gz
Revert "removing $(srcdir) because it is not replaced correctly and not necessary"
This reverts commit 17ef691e9b3ebd475b01d1e623d3df7b1f534dfa. This breaks builddir != srcdir builds, like GNOME Continuous.
Diffstat (limited to 'tests/offsets/Makefile.am')
-rw-r--r--tests/offsets/Makefile.am4
1 files changed, 2 insertions, 2 deletions
diff --git a/tests/offsets/Makefile.am b/tests/offsets/Makefile.am
index 0130ee52..a40e90bf 100644
--- a/tests/offsets/Makefile.am
+++ b/tests/offsets/Makefile.am
@@ -24,7 +24,7 @@ Offsets-1.0.gir: liboffsets.la offsets.h
Offsets_1_0_gir_INCLUDES = GObject-2.0
Offsets_1_0_gir_LIBS = liboffsets.la
Offsets_1_0_gir_PACKAGES = gobject-2.0
-Offsets_1_0_gir_FILES = offsets.h offsets.c
+Offsets_1_0_gir_FILES = $(srcdir)/offsets.h $(srcdir)/offsets.c
Offsets_1_0_gir_SCANNERFLAGS = $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error -I$(top_srcdir)/tests
INTROSPECTION_GIRS += Offsets-1.0.gir
@@ -39,7 +39,7 @@ gitestoffsets_CPPFLAGS = $(GIREPO_CFLAGS) -I$(top_srcdir)/girepository -I$(top_s
gitestoffsets_LDADD = $(top_builddir)/libgirepository-1.0.la $(GIREPO_LIBS)
gitestoffsets.c: gen-gitestoffsets offsets.h Offsets-1.0.typelib
- $(AM_V_GEN) $(PYTHON) gen-gitestoffsets offsets.h > $@ || ( rm -f $@ && false )
+ $(AM_V_GEN) $(PYTHON) $(srcdir)/gen-gitestoffsets $(srcdir)/offsets.h > $@ || ( rm -f $@ && false )
EXTRA_DIST += gen-gitestoffsets
BUILT_SOURCES += gitestoffsets.c