summaryrefslogtreecommitdiff
path: root/tests/offsets/meson.build
diff options
context:
space:
mode:
authorJohn Ericson <John.Ericson@Obsidian.Systems>2021-02-23 13:11:22 -0500
committerJohn Ericson <John.Ericson@Obsidian.Systems>2021-05-23 12:56:21 -0400
commitf9c1b6f65bec623d593835c400d2d55d981715c8 (patch)
tree2fbcc56bc165ba6d15268eb2e22588027e2a26d0 /tests/offsets/meson.build
parent00bce5569b5e7fd0f6e373857a89996e07bf0725 (diff)
downloadgobject-introspection-f9c1b6f65bec623d593835c400d2d55d981715c8.tar.gz
Make test suite work with cross-related options
Because of skepticism I received in #224, I made this PR which keeps the testsuite and CI improvements but doesn't add any new build options. I hope this would be less controversial: - no new knobs - tests for those using existing build options - CI tests `build_introspection_data = false`
Diffstat (limited to 'tests/offsets/meson.build')
-rw-r--r--tests/offsets/meson.build5
1 files changed, 2 insertions, 3 deletions
diff --git a/tests/offsets/meson.build b/tests/offsets/meson.build
index f6a497f6..970e54cf 100644
--- a/tests/offsets/meson.build
+++ b/tests/offsets/meson.build
@@ -18,8 +18,7 @@ if glib_dep.type_name() == 'pkgconfig'
output: 'Offsets-1.0.gir',
depends: [test_offsets_lib] + typelibs,
command: [
- python,
- girscanner,
+ test_girscanner,
'--quiet',
'--output=@OUTPUT@',
'--no-libtool',
@@ -45,7 +44,7 @@ if glib_dep.type_name() == 'pkgconfig'
input: test_offsets_gir,
output: '@BASENAME@.typelib',
depends: [gobject_gir, ],
- command: [gircompiler, '-o', '@OUTPUT@', '@INPUT@',
+ command: [test_gircompiler, '-o', '@OUTPUT@', '@INPUT@',
'--includedir', join_paths(build_root, 'gir'),
'--includedir', meson.current_build_dir()
],