summaryrefslogtreecommitdiff
path: root/tests/repository/Makefile.am
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gmail.com>2011-08-22 02:49:51 -0400
committerColin Walters <walters@verbum.org>2011-08-23 10:15:29 -0400
commit3a308bb438246f7d6e87ebe2f6efeb1795fdcd1e (patch)
treec8fabd232cb6cdaadd3fcf974e0f3b66629cc148 /tests/repository/Makefile.am
parent0bc07516cf964d42719844a29907ec20ad433652 (diff)
downloadgobject-introspection-3a308bb438246f7d6e87ebe2f6efeb1795fdcd1e.tar.gz
tests: build tests only on make check
Use automake's check_ prefix and avoid putting anything nontrivial in BUILT_SOURCES so that tests are build only on make check. The dummy -rpath in AM_LDFLAGS in tests/scanner/Makefile.am is needed to force libtool to build shared libraries for check_LTLIBRARIESS targets (automake builds check_LTLIBRARIES as static by default); see http://lists.gnu.org/archive/html/automake/2005-10/msg00107.html https://bugzilla.gnome.org/show_bug.cgi?id=657066
Diffstat (limited to 'tests/repository/Makefile.am')
-rw-r--r--tests/repository/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/repository/Makefile.am b/tests/repository/Makefile.am
index 268d9f9c..ffc635fe 100644
--- a/tests/repository/Makefile.am
+++ b/tests/repository/Makefile.am
@@ -2,7 +2,7 @@ AM_CFLAGS = $(GOBJECT_CFLAGS)
AM_LDFLAGS = -module -avoid-version
LIBS = $(GOBJECT_LIBS)
-noinst_PROGRAMS = gitestrepo gitestthrows gitypelibtest
+check_PROGRAMS = gitestrepo gitestthrows gitypelibtest
gitestrepo_SOURCES = $(srcdir)/gitestrepo.c
gitestrepo_CPPFLAGS = $(GIREPO_CFLAGS) -I$(top_srcdir)/girepository