summaryrefslogtreecommitdiff
path: root/tests/repository/Makefile.am
diff options
context:
space:
mode:
authorTorsten Schönfeld <kaffeetisch@gmx.de>2011-09-10 16:52:51 +0200
committerTorsten Schönfeld <kaffeetisch@gmx.de>2011-09-11 00:34:28 +0200
commitea68ec234ad31b0a1d92adbf0c911a5dd541b647 (patch)
tree125930f400320b4bddfa7948396a10915f83c1b5 /tests/repository/Makefile.am
parentc3da3d46ffa9c3b53e7f7132eaa9c9c722ebc859 (diff)
downloadgobject-introspection-ea68ec234ad31b0a1d92adbf0c911a5dd541b647.tar.gz
scanner: correctly handle structs with arrays of anon unions
This applies mainly to GValue, which is defined as: struct _GValue { /*< private >*/ GType g_type; /* public for GTypeValueTable methods */ union { gint v_int; guint v_uint; glong v_long; gulong v_ulong; gint64 v_int64; guint64 v_uint64; gfloat v_float; gdouble v_double; gpointer v_pointer; } data[2]; }; Previously, the scanner did not understand the array of unions. This resulted in g_struct_info_get_size returning an incorrect size for GValue (at least on 32bit systems). Fix this by making up a separate union declaration for the GIR that can be referenced by the array. https://bugzilla.gnome.org/show_bug.cgi?id=657040
Diffstat (limited to 'tests/repository/Makefile.am')
-rw-r--r--tests/repository/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/repository/Makefile.am b/tests/repository/Makefile.am
index ffc635fe..6331cd30 100644
--- a/tests/repository/Makefile.am
+++ b/tests/repository/Makefile.am
@@ -17,5 +17,5 @@ gitypelibtest_CPPFLAGS = $(GIREPO_CFLAGS) -I$(top_srcdir)/girepository
gitypelibtest_LDADD = $(top_builddir)/libgirepository-1.0.la $(GIREPO_LIBS)
TESTS = gitestrepo gitestthrows gitypelibtest
-TESTS_ENVIRONMENT=env GI_TYPELIB_PATH=$(top_builddir):$(top_builddir)/tests \
+TESTS_ENVIRONMENT=env GI_TYPELIB_PATH=$(top_builddir):$(top_builddir)/tests:$(top_builddir)/tests/scanner \
XDG_DATA_DIRS="$(top_srcdir)/gir:$(XDG_DATA_DIRS)" $(DEBUG)