summaryrefslogtreecommitdiff
path: root/tests/scanner/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@src.gnome.org>2008-10-12 04:51:48 +0000
committerColin Walters <walters@src.gnome.org>2008-10-12 04:51:48 +0000
commit2d6a7c97d16cd56a01b6d044cc7048e01344799d (patch)
treee739a70f3f6f62323be09e8d83574e20c5b6eda2 /tests/scanner/Makefile.am
parent8210400fe121dd9ba2694d4d6049b29beaa12eaa (diff)
downloadgobject-introspection-2d6a7c97d16cd56a01b6d044cc7048e01344799d.tar.gz
Bug 552858: versioning
This is a big patch. You should probably remove your installation tree to be cleaner. * docs/typelib-format.txt: Add nsversion entry which holds version of namespace. * girepository/girepository.h: Add 'version' parameter to g_irepository_require. This may be NULL. Normally bindings should pass an explicit version though. * girepository/girepository.c: Lots of infrastructure to support versioning. Add some more documentation. Disallow some usage of NULL namespaces. * girepository/girmodule.c: Add version parameter. * girepository/gtypelib.c: Update header size. * giscanner/ast.py: Add version to Namespace. * giscanner/girparser.py: Parse version attribute from XML, pass to Namespace. * giscanner/girwriter.py: Write out version parameter. * giscanner/transformer.py: Clean up include registration. * tests/*: Add version attribute. * tests/invoke/invoke.c: Don't try looking up test before it's loaded in repository. * tools/generate.c: Output version parameter. * gir/Makefile.am: Add 2.0 version to .gir files. svn path=/trunk/; revision=677
Diffstat (limited to 'tests/scanner/Makefile.am')
-rw-r--r--tests/scanner/Makefile.am48
1 files changed, 36 insertions, 12 deletions
diff --git a/tests/scanner/Makefile.am b/tests/scanner/Makefile.am
index fc6fd21a..2bf78d13 100644
--- a/tests/scanner/Makefile.am
+++ b/tests/scanner/Makefile.am
@@ -34,28 +34,52 @@ CLEANFILES = $(TYPELIBS) $(TXMLS) $(GIRS)
BUILT_SOURCES = $(TYPELIBS) $(TXMLS) $(GIRS)
EXTRA_DIST = $(EXPECTEDGIRS)
-%.gir: lib%.la %.c %.h utility.gir $(SCANNER) $(SCANNER_LIBS) Makefile
+annotation-1.0.gir: libannotation.la annotation.c annotation.h utility-1.0.gir $(SCANNER) $(SCANNER_LIBS) Makefile
PYTHONPATH=$(top_builddir):$$PYTHONPATH $(CHECK_DEBUG) $(SCANNER) -v \
- --include=$(top_srcdir)/gir/GObject.gir \
- --include=$(top_builddir)/tests/scanner/utility.gir \
- --library=$* \
- --namespace=$* \
+ --include=$(top_srcdir)/gir/GObject-2.0.gir \
+ --include=$(top_builddir)/tests/scanner/utility-1.0.gir \
+ --library=annotation \
+ --namespace=annotation \
+ --nsversion=1.0 \
--pkg gobject-2.0 \
- $(srcdir)/$*.h $(srcdir)/$*.c \
+ $(srcdir)/annotation.h $(srcdir)/annotation.c \
--output $@
-GIRS += annotation.gir
-GIRS += drawable.gir
-GIRS += foo.gir
+GIRS += annotation-1.0.gir
-utility.gir: libutility.la utility.h $(SCANNER) $(SCANNER_LIBS) Makefile
+drawable-1.0.gir: libdrawable.la drawable.c drawable.h utility-1.0.gir $(SCANNER) $(SCANNER_LIBS) Makefile
PYTHONPATH=$(top_builddir):$$PYTHONPATH $(CHECK_DEBUG) $(SCANNER) -v \
- --include=$(top_srcdir)/gir/GObject.gir \
+ --include=$(top_srcdir)/gir/GObject-2.0.gir \
+ --include=$(top_builddir)/tests/scanner/utility-1.0.gir \
+ --library=drawable \
+ --namespace=drawable \
+ --nsversion=1.0 \
+ --pkg gobject-2.0 \
+ $(srcdir)/drawable.h $(srcdir)/drawable.c \
+ --output $@
+GIRS += drawable-1.0.gir
+
+foo-1.0.gir: libfoo.la foo.c foo.h utility-1.0.gir $(SCANNER) $(SCANNER_LIBS) Makefile
+ PYTHONPATH=$(top_builddir):$$PYTHONPATH $(CHECK_DEBUG) $(SCANNER) -v \
+ --include=$(top_srcdir)/gir/GObject-2.0.gir \
+ --include=$(top_builddir)/tests/scanner/utility-1.0.gir \
+ --library=foo \
+ --namespace=foo \
+ --nsversion=1.0 \
+ --pkg gobject-2.0 \
+ $(srcdir)/foo.h $(srcdir)/foo.c \
+ --output $@
+GIRS += foo-1.0.gir
+
+utility-1.0.gir: libutility.la utility.h $(SCANNER) $(SCANNER_LIBS) Makefile
+ PYTHONPATH=$(top_builddir):$$PYTHONPATH $(CHECK_DEBUG) $(SCANNER) -v \
+ --include=$(top_srcdir)/gir/GObject-2.0.gir \
--library=utility \
--namespace=utility \
+ --nsversion=1.0 \
--pkg gobject-2.0 \
$(libutility_la_SOURCES) \
--output $@
-GIRS += utility.gir
+GIRS += utility-1.0.gir
pre-check:
@if test "$(top_builddir)" != "$(top_srcdir)"; then \