summaryrefslogtreecommitdiff
path: root/tests/scanner/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2013-04-10 00:00:37 +0200
committerColin Walters <walters@verbum.org>2013-04-21 08:34:33 -0400
commit274d4f28a00d1d2bbfc4a1fe4dbbd4ad545b1ec3 (patch)
tree71835f2996237c36ad988ee3ef1c91b2da7b10be /tests/scanner/Makefile.am
parent0f207646c63c8ee919b3a99436a53b977aece094 (diff)
downloadgobject-introspection-274d4f28a00d1d2bbfc4a1fe4dbbd4ad545b1ec3.tar.gz
fix "make distcheck"
- Configure with --enable-doctool when running "make distcheck" - Remove $(top_builddir)/.make-check-passed as the pre-commit hook using this was removed in de84ea0cf212c251e099f456bb675492f664e93d - Fix CLEANFILES + manual rm invocations - Fix running warning tests uninstalled (VPATH build issue) https://bugzilla.gnome.org/show_bug.cgi?id=697669
Diffstat (limited to 'tests/scanner/Makefile.am')
-rw-r--r--tests/scanner/Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/tests/scanner/Makefile.am b/tests/scanner/Makefile.am
index 31487a6b..faf29470 100644
--- a/tests/scanner/Makefile.am
+++ b/tests/scanner/Makefile.am
@@ -142,6 +142,7 @@ GIRS += Bar-1.0.gir
endif
EXTRA_DIST += headeronly.h
+CLEANFILES += Headeronly-1.0.gir
Headeronly-1.0.gir: headeronly.h
$(AM_V_GEN) $(INTROSPECTION_SCANNER) $(INTROSPECTION_SCANNER_ARGS) --warn-all --warn-error --reparse-validate --namespace=Headeronly --nsversion=1.0 --header-only --output=$@ $<
@@ -153,21 +154,23 @@ if BUILD_DOCTOOL
DOCGIRS = Regress-1.0.gir
CHECKDOCS = $(DOCGIRS:.gir=-C.page.check) $(DOCGIRS:.gir=-Python.page.check) $(DOCGIRS:.gir=-Gjs.page.check)
MALLARD_DIRS = $(DOCGIRS:.gir=-C) $(DOCGIRS:.gir=-Python) $(DOCGIRS:.gir=-Gjs)
+MALLARD_CLEAN = $(DOCGIRS:.gir=-C)/* $(DOCGIRS:.gir=-Python)/* $(DOCGIRS:.gir=-Gjs)/*
EXPECTED_MALLARD_DIRS = $(MALLARD_DIRS:=-expected)
+CLEANFILES += $(MALLARD_CLEAN)
%-C: %.gir
$(AM_V_GEN)
- $(AM_V_at)rm -f $*-C/*.page
+ $(AM_V_at)rm -rf $*-C
$(AM_V_at)$(INTROSPECTION_DOCTOOL) $(INTROSPECTION_DOCTOOL_ARGS) --language C $*.gir -o $*-C/
%-Python: %.gir
$(AM_V_GEN)
- $(AM_V_at)rm -f $*-Python/*.page
+ $(AM_V_at)rm -rf $*-Python
$(AM_V_at)$(INTROSPECTION_DOCTOOL) $(INTROSPECTION_DOCTOOL_ARGS) --language Python $*.gir -o $*-Python/
%-Gjs: %.gir
$(AM_V_GEN)
- $(AM_V_at)rm -f $*-Gjs/*.page
+ $(AM_V_at)rm -rf $*-Gjs
$(AM_V_at)$(INTROSPECTION_DOCTOOL) $(INTROSPECTION_DOCTOOL_ARGS) --language Gjs $*.gir -o $*-Gjs/
%-C.page.check: %-C