summaryrefslogtreecommitdiff
path: root/tests/scanner/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2013-08-12 16:54:11 +0200
committerDieter Verfaillie <dieterv@optionexplicit.be>2013-10-08 20:55:46 +0200
commita2b22ce75937d2d996ef90e0ab683d36031365d0 (patch)
tree42a1e8e7ba992a89efd98fa41b2d5e013f7165b2 /tests/scanner/Makefile.am
parent839e4f10a6b291a261c200484ff05ec44a31d93e (diff)
downloadgobject-introspection-a2b22ce75937d2d996ef90e0ab683d36031365d0.tar.gz
giscanner: flesh out annotation parsing and storage
- remove annotations regex, restore proper parens parsing - drop weird DocOption() storage class and use lists/dicts as appropriate - make GtkDocAnnotations a simple OrderedDict subclass instead of a weird hybrid dict/list storage class - Deprecate Attribute: tag, replace with (attributes) annotation on the identifier
Diffstat (limited to 'tests/scanner/Makefile.am')
-rw-r--r--tests/scanner/Makefile.am1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/scanner/Makefile.am b/tests/scanner/Makefile.am
index 0957a5f7..aa5b55af 100644
--- a/tests/scanner/Makefile.am
+++ b/tests/scanner/Makefile.am
@@ -202,6 +202,7 @@ EXTRA_DIST += \
annotationparser/tests.xsd \
annotationparser/gi/annotation_allow_none.xml \
annotationparser/gi/annotation_array.xml \
+ annotationparser/gi/annotation_attributes.xml \
annotationparser/gi/annotation_closure.xml \
annotationparser/gi/annotation_constructor.xml \
annotationparser/gi/annotation_destroy.xml \