summaryrefslogtreecommitdiff
path: root/tests/scanner/Makefile.am
diff options
context:
space:
mode:
authorColin Walters <walters@verbum.org>2010-09-14 13:05:48 -0400
committerColin Walters <walters@verbum.org>2010-09-14 13:05:48 -0400
commitc29368bab2ad74958376576d18365898c6b7ca39 (patch)
treeea0df22794a5733fdcd6fb4c20c916322295d1ea /tests/scanner/Makefile.am
parent4f68350184bc6a4b1e28e93a631ec7620f6af050 (diff)
downloadgobject-introspection-c29368bab2ad74958376576d18365898c6b7ca39.tar.gz
tests: Don't build regress if we don't HAVE_CAIRO
https://bugzilla.gnome.org/show_bug.cgi?id=629359
Diffstat (limited to 'tests/scanner/Makefile.am')
-rw-r--r--tests/scanner/Makefile.am7
1 files changed, 6 insertions, 1 deletions
diff --git a/tests/scanner/Makefile.am b/tests/scanner/Makefile.am
index 0fae2e04..1801c451 100644
--- a/tests/scanner/Makefile.am
+++ b/tests/scanner/Makefile.am
@@ -10,8 +10,11 @@ testlib_LTLIBRARIES = \
libtestinherit.la \
libfoo.la \
libutility.la \
- libregress.la \
libgtkfrob.la
+if HAVE_CAIRO
+testlib_LTLIBRARIES += libregress.la
+endif
+
testlibdir = $(prefix)/unused
install-testlibLTLIBRARIES: # prevent it from being installed
@@ -53,7 +56,9 @@ Regress-1.0.gir: $(top_builddir)/gir/Gio-2.0.gir libregress.la
Regress_1_0_gir_LIBS = libregress.la
Regress_1_0_gir_INCLUDES = cairo-1.0 Gio-2.0
Regress_1_0_gir_FILES = $(libregress_la_SOURCES)
+if HAVE_CAIRO
GIRS += Regress-1.0.gir
+endif
Annotation-1.0.gir: Utility-1.0.gir libannotation.la
Annotation_1_0_gir_PACKAGES = gobject-2.0