summaryrefslogtreecommitdiff
path: root/tests/scanner/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-12-20 18:09:10 +0100
committerChristoph Reiter <reiter.christoph@gmail.com>2018-12-20 18:09:10 +0100
commit13e8c7ff80f9ff2dc77e9d0da4b7396182c63612 (patch)
treef529b1752c1719c8c8c5396f1a0a732631e0bb66 /tests/scanner/meson.build
parent698c78f50e5e6ea638bea8f10398bdfe8691ac48 (diff)
downloadgobject-introspection-13e8c7ff80f9ff2dc77e9d0da4b7396182c63612.tar.gz
tests: make scanner tests work with msvc + subprojects
Manually add all the subproject build directories to PATH for running the scanner tests. I'm wondering if meson shouldn't do this for us based on the dependency we pass to test(), but this will do for now.
Diffstat (limited to 'tests/scanner/meson.build')
-rw-r--r--tests/scanner/meson.build24
1 files changed, 10 insertions, 14 deletions
diff --git a/tests/scanner/meson.build b/tests/scanner/meson.build
index cc5ee530..62809169 100644
--- a/tests/scanner/meson.build
+++ b/tests/scanner/meson.build
@@ -1,24 +1,20 @@
-
scanner_test_env = environment()
-scanner_test_env.append('PYTHONPATH', join_paths(meson.current_build_dir(), '../../'))
+scanner_test_env.prepend('PYTHONPATH', test_env_common_pypath)
+if test_env_common_path.length() > 0
+ scanner_test_env.prepend('PATH', test_env_common_path)
+endif
scanner_test_files = [
'test_shlibs.py',
+ 'test_sourcescanner.py',
+ 'test_transformer.py',
+ 'test_xmlwriter.py',
+ 'test_pkgconfig.py',
+ 'test_docwriter.py',
]
-# FIXME: MSVC
-if cc.get_id() != 'msvc'
- scanner_test_files += [
- 'test_sourcescanner.py',
- 'test_transformer.py',
- 'test_xmlwriter.py',
- 'test_pkgconfig.py',
- 'test_docwriter.py',
- ]
-endif
-
foreach f : scanner_test_files
- test(f, python, args: files(f), env: scanner_test_env)
+ test(f, python, args: files(f), env: scanner_test_env, depends: [giscanner_pymod])
endforeach
subdir('annotationparser')