summaryrefslogtreecommitdiff
path: root/tests/scanner/meson.build
diff options
context:
space:
mode:
authorTomasz Miąsko <tomasz.miasko@gmail.com>2018-04-27 00:00:00 +0000
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-11 09:16:14 +0200
commita41abe1868a693387cd5cf85567cf2e0fd6c62df (patch)
tree6b02fbbee3a66cd19514e9b032ae13ed849463af /tests/scanner/meson.build
parenteaabc3ba8a827ca1455acc44c1d7c73e2a92bee4 (diff)
downloadgobject-introspection-a41abe1868a693387cd5cf85567cf2e0fd6c62df.tar.gz
Avoid accidental library name matches when parsing ldd output.
* Use a single pattern that matches against potentially complete paths. * Extract filename only afterwards on platforms where it is necessary. * Match patterns against complete words in ldd output instead of searching for them inside the lines - this avoids unintentional matches without complexity of negative lookbehinds and negative lookaheads. Fixes issue #208.
Diffstat (limited to 'tests/scanner/meson.build')
-rw-r--r--tests/scanner/meson.build1
1 files changed, 1 insertions, 0 deletions
diff --git a/tests/scanner/meson.build b/tests/scanner/meson.build
index f8b794d2..3458c32e 100644
--- a/tests/scanner/meson.build
+++ b/tests/scanner/meson.build
@@ -3,6 +3,7 @@ scanner_test_env = environment()
scanner_test_env.append('PYTHONPATH', join_paths(meson.current_build_dir(), '../../'))
scanner_test_files = [
+ 'test_shlibs.py',
'test_sourcescanner.py',
'test_transformer.py'
]