summaryrefslogtreecommitdiff
path: root/tests/scanner/meson.build
diff options
context:
space:
mode:
authorChristoph Reiter <reiter.christoph@gmail.com>2018-07-11 18:49:27 +0200
committerChristoph Reiter <reiter.christoph@gmail.com>2018-07-11 20:44:52 +0200
commit2dbf8f4ea4992ca33c272786f860d7fc291ba89b (patch)
treefca28df47c9d2e3afc991c19de68fe80db477e18 /tests/scanner/meson.build
parent4542321c383304807228f204de600aa64944c87e (diff)
downloadgobject-introspection-2dbf8f4ea4992ca33c272786f860d7fc291ba89b.tar.gz
meson: Add a "python" option to make the python to build against configurable
This allows us to build with Python 2 and run tests with it. This requires the new "python" meson module which was added in 0.46.0 so bump the required meson version (glib needs a newer one anyway). Also fixes a small test error under Python 2.
Diffstat (limited to 'tests/scanner/meson.build')
-rw-r--r--tests/scanner/meson.build2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/scanner/meson.build b/tests/scanner/meson.build
index cd8df991..e64345a0 100644
--- a/tests/scanner/meson.build
+++ b/tests/scanner/meson.build
@@ -13,6 +13,6 @@ if host_system != 'windows'
endif
foreach f : scanner_test_files
- test(f, python3, args: files(f), env: scanner_test_env)
+ test(f, python, args: files(f), env: scanner_test_env)
endforeach