summaryrefslogtreecommitdiff
path: root/tests/warn/Makefile.am
diff options
context:
space:
mode:
authorJohan Dahlin <johan@gnome.org>2010-09-02 16:59:48 -0300
committerJohan Dahlin <johan@gnome.org>2010-09-02 17:19:03 -0300
commit4da9654e44eff6eb7c22510d89a3b00e969a16ab (patch)
tree3b747cca74c24d847d66bc3de5b2e1cca9caf64b /tests/warn/Makefile.am
parent64fe43160220f2145e8ce903772251f335e8ca2a (diff)
downloadgobject-introspection-4da9654e44eff6eb7c22510d89a3b00e969a16ab.tar.gz
[tests] Rework tester to be executed once per test
Instead of running all tests in the same instance
Diffstat (limited to 'tests/warn/Makefile.am')
-rw-r--r--tests/warn/Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/tests/warn/Makefile.am b/tests/warn/Makefile.am
index a1e274d3..aefc7a70 100644
--- a/tests/warn/Makefile.am
+++ b/tests/warn/Makefile.am
@@ -1,10 +1,10 @@
include $(top_srcdir)/common.mk
-warning_tests = \
+TESTS = \
return-gobject.h \
unresolved-type.h
EXTRA_DIST = warningtester.py common.h $(warning_tests)
-check-local:
- @PYTHONPATH=$(top_builddir):$(top_srcdir) $(PYTHON) $(srcdir)/warningtester.py $(warning_tests)
+TESTS_ENVIRONMENT = PYTHONPATH=$(top_builddir):$(top_srcdir) $(PYTHON) $(srcdir)/warningtester.py
+