summaryrefslogtreecommitdiff
path: root/tests/warn/Makefile.am
diff options
context:
space:
mode:
authorDieter Verfaillie <dieterv@optionexplicit.be>2012-04-17 22:23:14 +0200
committerDieter Verfaillie <dieterv@optionexplicit.be>2012-04-17 23:03:22 +0200
commitc87ef59b4b4e57f7704144c2098b5ab0bf37976e (patch)
tree37b5651810377b9b1d75ad6a8d01ac03f1e81608 /tests/warn/Makefile.am
parentf4729860f3b397a868a6e9135ce51975b1d043f1 (diff)
downloadgobject-introspection-c87ef59b4b4e57f7704144c2098b5ab0bf37976e.tar.gz
annotationparser: cleanup and add tests for the new warnings we now emit
Including: - handle things in the logical order encountered (first colon, then annotations) - correctly report column when missing a colon on the identifier part - small type fixes - remove no longer useful "parameter/tag expected" warnings
Diffstat (limited to 'tests/warn/Makefile.am')
-rw-r--r--tests/warn/Makefile.am2
1 files changed, 1 insertions, 1 deletions
diff --git a/tests/warn/Makefile.am b/tests/warn/Makefile.am
index 5ca3d821..c4354223 100644
--- a/tests/warn/Makefile.am
+++ b/tests/warn/Makefile.am
@@ -1,6 +1,7 @@
include $(top_srcdir)/common.mk
TESTS = \
+ annotationparser.h \
callback-invalid-scope.h \
callback-missing-scope.h \
return-gobject.h \
@@ -19,4 +20,3 @@ TESTS = \
EXTRA_DIST = warningtester.py common.h $(TESTS)
TESTS_ENVIRONMENT = PYTHONPATH=$(top_builddir):$(top_srcdir) TOP_BUILDDIR=$(top_builddir) UNINSTALLED_INTROSPECTION_SRCDIR=$(top_srcdir) $(PYTHON) $(srcdir)/warningtester.py
-