summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 9 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index de8bab33..940fc1a1 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -55,14 +55,19 @@ EXTRA_DIST += \
misc/pre-commit \
misc/pyflakes.py
-release-tag:
+prepare-release-tag:
@TAG=`echo $(VERSION)|sed s/\\\./_/g`;\
- echo "* Tagging $(VERSION)"; \
+ echo "git tag GOBJECT_INTROSPECTION_$$TAG"; \
git tag -m "Tag $$VERSION" -a \
- GOBJECT_INTROSPECTION_$$TAG && \
- git push --tags ssh://git.gnome.org/git/gobject-introspection
+ GOBJECT_INTROSPECTION_$$TAG
+
+prepare-minor-release: $(distdir).tar.bz2 prepare-release-tag
+ python $(top_srcdir)/tools/verbump.py
upload-release: $(distdir).tar.bz2
+ git log origin/master..master
+ @echo -n "Ok to push? [y/N] "; read ans; test x$$ans == xy || exit 1
+ git push --tags origin master:master
scp $(distdir).tar.bz2 gnome.org:
ssh gnome.org install-module $(distdir).tar.bz2