summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 4 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 9904c395..78187eb7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -42,10 +42,10 @@ upload-release: $(distdir).tar.gz
ssh gnome.org install-module $(distdir).tar.gz
check-local:
- @test -f .git/hooks/pre-commit || (echo -e "ERROR: missing \
- pre-commit hook.\n\ncopy misc/pre-commit to .git/hooks"; false)
- @test -x .git/hooks/pre-commit || (echo -e "ERROR: pre-commit \
- is not executable\n\nrun chmod +x .git/hooks/pre-commit"; false)
+ @test ! -d $(top_srcdir)/.git || (test -f .git/hooks/pre-commit || (echo -e "ERROR: missing \
+ pre-commit hook.\n\ncopy misc/pre-commit to .git/hooks"; false))
+ @test ! -d $(top_srcdir)/.git || (test -x .git/hooks/pre-commit || (echo -e "ERROR: pre-commit \
+ is not executable\n\nrun chmod +x .git/hooks/pre-commit"; false))
@echo " PEP-8 INQUISITION"
@find $(top_srcdir)/giscanner -name \*.py | sort | uniq | xargs $(PYTHON) $(top_srcdir)/misc/pep8.py --repeat --exclude=config.py
@echo " CHECK Pyflakes"