summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index 8eef4712..a901c0b2 100644
--- a/configure.ac
+++ b/configure.ac
@@ -37,21 +37,21 @@ PKG_CHECK_MODULES(SCANNER, [gobject-2.0 gthread-2.0])
dnl libffi
PKG_CHECK_MODULES(FFI, libffi, have_ffi_pkgconfig=yes, have_ffi_pkgconfig=no)
-if x$have_ffi_pkgconfig = xno ; then
+if test x"$have_ffi_pkgconfig" = xno ; then
AC_MSG_CHECKING(for ffi.h)
AC_TRY_CPP([#include <ffi.h>], have_ffi_h=yes, have_ffi_h=no)
- if test $have_ffi_h = yes; then
+ if test x"$have_ffi_h" = x"yes"; then
save_LIBS=$LIBS
- if test x"$with_ffi" = xyes || test x"$with_ffi" = xauto; then
+ if test x"$with_ffi" = x"yes" || test x"$with_ffi" = x"auto"; then
other_LIBS=
else
other_LIBS=$with_ffi
fi
AC_SEARCH_LIBS(ffi_call,ffi,,AC_MSG_ERROR([libffi not found]),$other_LIBS)
- if test x$"ac_cv_search_ffi_call" = x"none required" ; then
+ if test x"$ac_cv_search_ffi_call" = x"none required" ; then
FFI_LIBS=$other_LIBS
else
FFI_LIBS="$ac_cv_search_ffi_call $other_LIBS"
@@ -59,7 +59,7 @@ if x$have_ffi_pkgconfig = xno ; then
LIBS=$save_LIBS
fi
- if test x"$have_ffi_h" != xyes ; then
+ if test x"$have_ffi_h" != x"yes" ; then
AC_MSG_ERROR([ffi.h not found])
fi