summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 230ab2e8..5202bdcf 100644
--- a/configure.ac
+++ b/configure.ac
@@ -46,6 +46,29 @@ if test "$YACC" = :; then
AC_MSG_ERROR([bison not found but required])
fi
+changequote(,)dnl
+ensureflag() {
+ flag="$1"; shift
+ result="$@"
+
+ case " ${result} " in
+ *[\ \ ]${flag}[\ \ ]*) ;;
+ *) result="${flag} ${result}" ;;
+ esac
+
+ echo ${result}
+}
+changequote([,])dnl
+
+if test "$GCC" = "yes"; then
+ for flag in -Wall -Wchar-subscripts -Wmissing-declarations \
+ -Wmissing-prototypes -Wnested-externs -Wpointer-arith -Wcast-align \
+ -Wsign-compare -fno-strict-aliasing;
+ do
+ CFLAGS="$(ensureflag $flag $CFLAGS)"
+ done
+fi
+
# Checks for libraries.
GI_ENABLE_GCOV