summaryrefslogtreecommitdiff
path: root/gir/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'gir/meson.build')
-rw-r--r--gir/meson.build28
1 files changed, 9 insertions, 19 deletions
diff --git a/gir/meson.build b/gir/meson.build
index 04f9371a..557e5517 100644
--- a/gir/meson.build
+++ b/gir/meson.build
@@ -41,24 +41,14 @@ gir_files = [
typelibdir = join_paths(get_option('libdir'), 'girepository-1.0')
install_data(gir_files, install_dir: girdir)
-if get_option('gi_cross_use_host_gi')
- scanner_command = [
- 'g-ir-scanner',
- ]
-else
- scanner_command = [
- python,
- girscanner,
- ]
-endif
-
-scanner_command += [
- '--output=@OUTPUT@',
- '--no-libtool',
- '--quiet',
- '--reparse-validate',
- '--add-include-path', join_paths(meson.current_build_dir()),
- '--add-include-path', join_paths(meson.current_source_dir()),
+scanner_command = [
+ find_program('g-ir-scanner', native: true),
+ '--output=@OUTPUT@',
+ '--no-libtool',
+ '--quiet',
+ '--reparse-validate',
+ '--add-include-path', join_paths(meson.current_build_dir()),
+ '--add-include-path', join_paths(meson.current_source_dir()),
]
dep_type = glib_dep.type_name()
@@ -458,7 +448,7 @@ foreach gir : gir_files
typelibs += custom_target('generate-typelib-@0@'.format(gir).underscorify(),
input: gir,
output: '@BASENAME@.typelib',
- depends: [gobject_gir, ],
+ depends: [gobject_gir, gircompiler, ],
command: gircompiler_command,
install: true,
install_dir: typelibdir,