summaryrefslogtreecommitdiff
path: root/giscanner/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'giscanner/meson.build')
-rw-r--r--giscanner/meson.build12
1 files changed, 12 insertions, 0 deletions
diff --git a/giscanner/meson.build b/giscanner/meson.build
index 4998865a..6ae34067 100644
--- a/giscanner/meson.build
+++ b/giscanner/meson.build
@@ -49,6 +49,18 @@ endforeach
install_subdir('doctemplates', install_dir: giscannerdir)
+# XXX: this doesn't track the input, but there is nothing to copy many files
+# in meson.
+doc_templates = custom_target('copy-templates',
+ input : 'doctemplates',
+ output : 'doctemplates',
+ command : [
+ python, '-c',
+ 'import sys, shutil;' +
+ 'shutil.rmtree(sys.argv[2], ignore_errors=True);' +
+ 'shutil.copytree(sys.argv[1], sys.argv[2])',
+ '@INPUT@', '@OUTPUT@'])
+
flex = find_program('flex', 'win_flex')
bison = find_program('bison', 'win_bison')