summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build7
1 files changed, 7 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 3759c12b..cd647b04 100644
--- a/meson.build
+++ b/meson.build
@@ -151,6 +151,13 @@ if with_cairo
cairo_gobject_dep = cc.find_library ('cairo-gobject')
endif
endif
+else
+ warning('Not building with cairo support, not all tests will be run')
+endif
+
+with_doctool = get_option('doctool')
+if not with_doctool
+ warning('Not building with doctool support, not all tests will be run')
endif
subdir('girepository')