summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build9
1 files changed, 7 insertions, 2 deletions
diff --git a/meson.build b/meson.build
index 9638a5ab..4460e40c 100644
--- a/meson.build
+++ b/meson.build
@@ -218,14 +218,19 @@ subdir('giscanner')
# scenarios where running target binaries through software emulation
# is not possible (due to the SW emulation missing support for target HW).
if get_option('build_introspection_data') == true
- subdir('gir')
+ subdir('gir')
+else
+ # for tests
+ typelibs = disabler()
+ gobject_gir = disabler()
+ gio_gir = disabler()
endif
subdir('docs')
# The tests will also run, which is not possible if they
# were built for a different architecture.
if not meson.is_cross_build()
- subdir('tests')
+ subdir('tests')
endif
install_data('Makefile.introspection', install_dir: join_paths(get_option('datadir'), 'gobject-introspection-1.0'))