summaryrefslogtreecommitdiff
path: root/tests/doctool/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/doctool/Makefile.am')
-rw-r--r--tests/doctool/Makefile.am41
1 files changed, 20 insertions, 21 deletions
diff --git a/tests/doctool/Makefile.am b/tests/doctool/Makefile.am
index eff85e7e..5bb84a65 100644
--- a/tests/doctool/Makefile.am
+++ b/tests/doctool/Makefile.am
@@ -1,30 +1,29 @@
include $(top_srcdir)/common.mk
-# Disabled temporarily
+GIRS = GIRepository-2.0.gir
+CHECK_TARGETS = $(GIRS:.gir=-C.page.check) $(GIRS:.gir=-Python.page.check)
+MALLARD_DIRS = $(GIRS:.gir=-C) $(GIRS:.gir=-Python)
+EXPECTED_MALLARD_DIRS = $(MALLARD_DIRS:=-expected)
+CLEANFILES = $(GIRS)
+BUILT_SOURCES = $(MALLARD_DIRS)
+EXTRA_DIST = $(EXPECTED_MALLARD_DIRS)
-# GIRS = GIRepository-2.0.gir
-# CHECK_TARGETS = $(GIRS:.gir=-C.page.check) $(GIRS:.gir=-Python.page.check)
-# MALLARD_DIRS = $(GIRS:.gir=-C) $(GIRS:.gir=-Python)
-# EXPECTED_MALLARD_DIRS = $(MALLARD_DIRS:=-expected)
-# CLEANFILES = $(GIRS)
-# EXTRA_DIST = $(EXPECTED_MALLARD_DIRS)
+%.gir:
+ cp ../../$*.gir .
-# %.gir:
-# cp ../../$*.gir .
+%-C: %.gir
+ mkdir $*-C ; rm $*-C/*.page ; $(INTROSPECTION_DOCTOOL) --language C $*.gir -o $*-C/index.page && echo " GEN $*-C/index.page"
-# %-C: %.gir
-# mkdir $*-C ; rm $*-C/*.page ; $(INTROSPECTION_DOCTOOL) --language C --format mallard $*.gir -o $*-C/index.page && echo " GEN $*-C/index.page"
+%-Python: %.gir
+ mkdir $*-Python ; rm $*-Python/*.page ; $(INTROSPECTION_DOCTOOL) --language Python $*.gir -o $*-Python/index.page && echo " GEN $*-Python/index.page"
-# %-Python: %.gir
-# mkdir $*-Python ; rm $*-Python/*.page ; $(INTROSPECTION_DOCTOOL) --language Python --format mallard $*.gir -o $*-Python/index.page && echo " GEN $*-Python/index.page"
+%-C.page.check: %-C
+ @diff -u -U 10 $(srcdir)/$*-C-expected $*-C && echo " TEST $*-C" && rm -rf $*-C
-# %-C.page.check: %-C
-# @diff -u -U 10 $(srcdir)/$*-C-expected $*-C && echo " TEST $*-C" && rm -rf $*-C
+%-Python.page.check: %-Python
+ @diff -u -U 10 $(srcdir)/$*-Python-expected $*-Python && echo " TEST $*-Python" && rm -rf $*-Python
-# %-Python.page.check: %-Python
-# @diff -u -U 10 $(srcdir)/$*-Python-expected $*-Python && echo " TEST $*-Python" && rm -rf $*-Python
+check-local: $(CHECK_TARGETS)
-# check-local: $(CHECK_TARGETS)
-
-# clean-local:
-# @rm -rf $(MALLARD_DIRS)
+clean-local:
+ @rm -rf $(MALLARD_DIRS)