summaryrefslogtreecommitdiff
path: root/tests/invoke/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/invoke/Makefile.am')
-rw-r--r--tests/invoke/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/tests/invoke/Makefile.am b/tests/invoke/Makefile.am
new file mode 100644
index 00000000..5163ef68
--- /dev/null
+++ b/tests/invoke/Makefile.am
@@ -0,0 +1,20 @@
+## Process this file with automake to produce Makefile.in
+
+bin_PROGRAMS = invoke
+noinst_LTLIBRARIES = testfns.la
+
+
+testfns_la_SOURCES = \
+ testfns.c \
+ testfns-metadata.c
+testfns_la_CFLAGS = $(GIREPO_CFLAGS)
+testfns_la_LDFLAGS = -module -avoid-version
+
+testfns-metadata.c: testfns.xml
+ ../../src/g-idl-compiler $(srcdir)/testfns.xml -o testfns-metadata.c
+
+
+invoke_SOURCES = invoke.c
+invoke_CFLAGS = $(GIREPO_CFLAGS) -I ../../src
+invoke_LDADD = $(GIREPO_LIBS) -ldl ../../src/libgirepository.la
+