summaryrefslogtreecommitdiff
path: root/tests/invoke/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/invoke/Makefile.am')
-rw-r--r--tests/invoke/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/invoke/Makefile.am b/tests/invoke/Makefile.am
index b56ca4dc..fa83d7be 100644
--- a/tests/invoke/Makefile.am
+++ b/tests/invoke/Makefile.am
@@ -16,11 +16,11 @@ testfns_la_LIBADD = $(GIREPO_LIBS) $(top_builddir)/girepository/libgirepository.
BUILT_SOURCES = testfns-metadata.c test.repo
CLEANFILES = testfns-metadata.c test.repo
-testfns-metadata.c: testfns.xml $(top_builddir)/tools/g-idl-compiler
- $(top_builddir)/tools/g-idl-compiler $(srcdir)/testfns.xml -o testfns-metadata.c
+testfns-metadata.c: testfns.gir $(top_builddir)/tools/g-ir-compiler
+ $(CHECK_DEBUG) $(top_builddir)/tools/g-ir-compiler $(srcdir)/testfns.gir -o testfns-metadata.c
-test.repo: testfns.xml
- $(top_builddir)/tools/g-idl-compiler --shared-library testfns.la $< --raw -o $@
+test.repo: testfns.gir
+ $(CHECK_DEBUG) $(top_builddir)/tools/g-ir-compiler --shared-library testfns.la $< --raw -o $@
invoke_SOURCES = invoke.c
invoke_CFLAGS = $(GIREPO_CFLAGS) -I$(top_srcdir)/girepository
@@ -28,6 +28,6 @@ invoke_LDADD = $(GIREPO_LIBS) $(top_builddir)/girepository/libgirepository.la
TESTS = invoke invoke-namespace-find.sh
-EXTRA_DIST = invoke-namespace-find.sh testfns.xml
+EXTRA_DIST = invoke-namespace-find.sh testfns.gir
TESTS_ENVIRONMENT = GIREPOPATH="."