summaryrefslogtreecommitdiff
path: root/tests/offsets/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/offsets/Makefile.am')
-rw-r--r--tests/offsets/Makefile.am10
1 files changed, 5 insertions, 5 deletions
diff --git a/tests/offsets/Makefile.am b/tests/offsets/Makefile.am
index 0df9c151..fa1c1001 100644
--- a/tests/offsets/Makefile.am
+++ b/tests/offsets/Makefile.am
@@ -41,7 +41,9 @@ gitestoffsets_LDADD = $(top_builddir)/libgirepository-1.0.la $(GIREPO_LIBS)
gitestoffsets.c: gen-gitestoffsets offsets.h Offsets-1.0.typelib
$(AM_V_GEN) $(PYTHON) $(srcdir)/gen-gitestoffsets $(srcdir)/offsets.h > $@ || ( rm -f $@ && false )
-EXTRA_DIST += gen-gitestoffsets
+EXTRA_DIST += \
+ gen-gitestoffsets \
+ test_offsets.py
BUILT_SOURCES += gitestoffsets.c
CLEANFILES += gitestoffsets.c $(EXTRA_PROGRAMS)
@@ -50,7 +52,5 @@ CLEANFILES += gitestoffsets.c $(EXTRA_PROGRAMS)
# The trailing "echo" in LOG_COMPILER is used to ignore automake passing
# gitestoffsets as we already run this in the same command line.
TESTS = gitestoffsets
-LOG_COMPILER = env GI_TYPELIB_PATH=:$(top_builddir) ./gitestoffsets$(EXEEXT) offsets.compiled offsets.introspected && \
- diff -u offsets.compiled offsets.introspected && echo
-
-CLEANFILES += offsets.compiled offsets.introspected
+TESTS_ENVIRONMENT = env top_builddir=$(top_builddir) builddir=$(builddir)
+LOG_COMPILER = $(PYTHON) $(srcdir)/test_offsets.py && echo