summaryrefslogtreecommitdiff
path: root/tests/repository/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/repository/meson.build')
-rw-r--r--tests/repository/meson.build22
1 files changed, 22 insertions, 0 deletions
diff --git a/tests/repository/meson.build b/tests/repository/meson.build
new file mode 100644
index 00000000..1281427e
--- /dev/null
+++ b/tests/repository/meson.build
@@ -0,0 +1,22 @@
+repository_tests = [
+ 'gitestrepo',
+ 'giteststructinfo',
+ 'gitestthrows',
+ # FIXME: Requires Regress typelib which is not yet ported to meson.
+ # 'gitypelibtest',
+]
+
+repository_test_env = environment()
+repository_test_env.append(
+ 'GI_TYPELIB_PATH',
+ join_paths(meson.build_root(), 'gir'),
+ join_paths(meson.build_root(), 'tests')
+)
+
+if glib_dep.type_name() == 'pkgconfig'
+ foreach test_name : repository_tests
+ source = files(test_name + '.c')
+ exe = executable(test_name, source, dependencies: [girepo_dep])
+ test(test_name, exe, env: repository_test_env)
+ endforeach
+endif