summaryrefslogtreecommitdiff
path: root/tests/scanner/annotationparser/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/scanner/annotationparser/meson.build')
-rw-r--r--tests/scanner/annotationparser/meson.build18
1 files changed, 6 insertions, 12 deletions
diff --git a/tests/scanner/annotationparser/meson.build b/tests/scanner/annotationparser/meson.build
index 954dc28d..cce8c5c7 100644
--- a/tests/scanner/annotationparser/meson.build
+++ b/tests/scanner/annotationparser/meson.build
@@ -1,20 +1,14 @@
annotationparser_test_env = environment()
-annotationparser_test_env.append('PYTHONPATH', join_paths(meson.current_build_dir(), '../../../'))
+annotationparser_test_env.prepend('PYTHONPATH', test_env_common_pypath)
+if test_env_common_path.length() > 0
+ annotationparser_test_env.prepend('PATH', test_env_common_path)
+endif
annotationparser_test_files = [
'test_patterns.py',
+ 'test_parser.py',
]
-# FIXME: MSVC
-# from giscanner._giscanner import SourceScanner as CSourceScanner
-# ImportError: DLL load failed: The specified module could not be found.
-if cc.get_id() != 'msvc'
- annotationparser_test_files += [
- 'test_parser.py',
- ]
-endif
-
foreach f : annotationparser_test_files
- test(f, python, args: files(f), env: annotationparser_test_env)
+ test(f, python, args: files(f), env: annotationparser_test_env, depends: [giscanner_pymod])
endforeach
-