summaryrefslogtreecommitdiff
path: root/tests/scanner/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/scanner/meson.build')
-rw-r--r--tests/scanner/meson.build11
1 files changed, 11 insertions, 0 deletions
diff --git a/tests/scanner/meson.build b/tests/scanner/meson.build
index a82a6135..50ca5a2b 100644
--- a/tests/scanner/meson.build
+++ b/tests/scanner/meson.build
@@ -137,6 +137,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -175,6 +176,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', join_paths(meson.build_root(), 'girepository'),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -212,6 +214,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -247,6 +250,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -284,6 +288,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -322,6 +327,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -359,6 +365,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -387,6 +394,7 @@ if glib_dep.type_name() == 'pkgconfig'
'--nsversion=1.0',
'--header-only',
'--symbol-filter-cmd=' + python_path + ' ' + join_paths(meson.current_source_dir(), 'symbolfilter.py'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -415,6 +423,7 @@ if glib_dep.type_name() == 'pkgconfig'
'--nsversion=1.0',
'--header-only',
'--identifier-filter-cmd=' + python_path + ' ' + join_paths(meson.current_source_dir(), 'identfilter.py'),
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -443,6 +452,7 @@ if glib_dep.type_name() == 'pkgconfig'
'--namespace=Headeronly',
'--nsversion=1.0',
'--header-only',
+ extra_giscanner_args,
'@INPUT@',
]
)
@@ -485,6 +495,7 @@ if glib_dep.type_name() == 'pkgconfig'
'-L', meson.current_build_dir(),
'-I', meson.current_source_dir(),
'-I', join_paths(meson.current_source_dir(), '..'),
+ extra_giscanner_args,
] + regress_scanner_cairo_args + [
'@INPUT@',
]