summaryrefslogtreecommitdiff
path: root/tests/scanner/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tests/scanner/meson.build')
-rw-r--r--tests/scanner/meson.build24
1 files changed, 10 insertions, 14 deletions
diff --git a/tests/scanner/meson.build b/tests/scanner/meson.build
index cc5ee530..62809169 100644
--- a/tests/scanner/meson.build
+++ b/tests/scanner/meson.build
@@ -1,24 +1,20 @@
-
scanner_test_env = environment()
-scanner_test_env.append('PYTHONPATH', join_paths(meson.current_build_dir(), '../../'))
+scanner_test_env.prepend('PYTHONPATH', test_env_common_pypath)
+if test_env_common_path.length() > 0
+ scanner_test_env.prepend('PATH', test_env_common_path)
+endif
scanner_test_files = [
'test_shlibs.py',
+ 'test_sourcescanner.py',
+ 'test_transformer.py',
+ 'test_xmlwriter.py',
+ 'test_pkgconfig.py',
+ 'test_docwriter.py',
]
-# FIXME: MSVC
-if cc.get_id() != 'msvc'
- scanner_test_files += [
- 'test_sourcescanner.py',
- 'test_transformer.py',
- 'test_xmlwriter.py',
- 'test_pkgconfig.py',
- 'test_docwriter.py',
- ]
-endif
-
foreach f : scanner_test_files
- test(f, python, args: files(f), env: scanner_test_env)
+ test(f, python, args: files(f), env: scanner_test_env, depends: [giscanner_pymod])
endforeach
subdir('annotationparser')