summaryrefslogtreecommitdiff
path: root/tests/warn/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/warn/Makefile.am')
-rw-r--r--tests/warn/Makefile.am8
1 files changed, 5 insertions, 3 deletions
diff --git a/tests/warn/Makefile.am b/tests/warn/Makefile.am
index c4354223..50e5ab15 100644
--- a/tests/warn/Makefile.am
+++ b/tests/warn/Makefile.am
@@ -1,6 +1,8 @@
include $(top_srcdir)/common.mk
-TESTS = \
+TESTS = warntestrunner
+
+alltests = \
annotationparser.h \
callback-invalid-scope.h \
callback-missing-scope.h \
@@ -17,6 +19,6 @@ TESTS = \
unknown-parameter.h \
unresolved-type.h
-EXTRA_DIST = warningtester.py common.h $(TESTS)
+EXTRA_DIST = warningtester.py warntestrunner common.h $(TESTS)
-TESTS_ENVIRONMENT = PYTHONPATH=$(top_builddir):$(top_srcdir) TOP_BUILDDIR=$(top_builddir) UNINSTALLED_INTROSPECTION_SRCDIR=$(top_srcdir) $(PYTHON) $(srcdir)/warningtester.py
+TESTS_ENVIRONMENT = PYTHONPATH=$(top_builddir):$(top_srcdir) TOP_BUILDDIR=$(top_builddir) UNINSTALLED_INTROSPECTION_SRCDIR=$(top_srcdir) PYTHON=$(PYTHON) srcdir=$(srcdir) alltests="$(alltests)"