summaryrefslogtreecommitdiff
path: root/tools/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'tools/meson.build')
-rw-r--r--tools/meson.build5
1 files changed, 4 insertions, 1 deletions
diff --git a/tools/meson.build b/tools/meson.build
index ea8ccc3a..73472664 100644
--- a/tools/meson.build
+++ b/tools/meson.build
@@ -19,13 +19,16 @@ foreach tool : tools
tools_conf.set('TOOL_MODULE', tool[1])
tools_conf.set('TOOL_FUNCTION', tool[2])
- tool_output += configure_file(
+ tool_bin = configure_file(
input: 'g-ir-tool-template.in',
output: tool[0],
configuration: tools_conf,
install: true,
install_dir: get_option('bindir'),
)
+ tool_output += tool_bin
+ # Provide tools for others when we're a subproject and they use the Meson GNOME module
+ meson.override_find_program(tool[0], tool_bin)
endforeach
girscanner = tool_output[0]