summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Post-release version bumpGOBJECT_INTROSPECTION_0_6_14Colin Walters2010-06-031-1/+1
|
* Fix marshalling of GStrv.GOBJECT_INTROSPECTION_0_6_13Tomeu Vizoso2010-06-027-7/+142
| | | | | | | | | | | | | | | | | | * gir/gimarshallingtests.[hc]: Add a test for GStrv in function args and as struct fields. * girepository/giroffsets.c: Correctly compute the size of structs with array fields * girepository/girparser.c: Set is_pointer to FALSE for arrays with fixed size that are inside structs. * giscanner/glibtransformer.py: Special case GStrv as arrays of utf8. * giscanner/annotationparser.py: Make full transfer the default for arrays of char* returned by functions. https://bugzilla.gnome.org/show_bug.cgi?id=620170
* Fix the relative path that contains the girepositoryheadersTomeu Vizoso2010-06-011-1/+1
|
* Add Cursor record to xlib-2.0.girTomeu Vizoso2010-06-011-0/+1
|
* [girepository] Fix the remaning headers as wellJohan Dahlin2010-06-015-10/+10
|
* [girepository] Fix include pathJohan Dahlin2010-06-015-5/+5
| | | | | | We're installing the headers without the girepository/ prefix, so remove that in all internal headers to not break the out of tree scanning.
* [gifunctioninfo] Move out to another fileJohan Dahlin2010-05-316-230/+296
| | | | Move out GIFunctionInfo to gifunctioninfo.[ch]
* Update .gitignoreJohan Dahlin2010-05-311-0/+1
|
* [gtypelib.ch] Rename to gitypelib.chJohan Dahlin2010-05-3112-12/+12
| | | | | Rename gtypelib.h -> gitypelib-internal.h and rename gtypelib.c to gitypelib.c
* [girepository] Split out GIBaseInfoJohan Dahlin2010-05-319-877/+1082
| | | | | | | | | Split out GIBaseInfo to a separate source file. Move out definitions to gibaseinfo.h/gitypelib.h/gitypes.h and girepository-private.h Install gibaseinfo.h/gitypelib.h and gitypes.h as well, but require users to include girepository.h
* [everything] Re-generate after doc changesJohan Dahlin2010-05-311-4/+2
| | | | | The gtk-doc parser is a big stricter now, which changed the weird comments written in everything.c
* [common.mk] Add -I$(top_srcdir)Johan Dahlin2010-05-311-0/+1
| | | | | This is needed to be able to find the public headers without having them installed.
* [giscanner] Parse multiline gtk-doc commentsJohan Dahlin2010-05-313-6/+16
|
* [docs] Fix a typo in the overviewJohan Dahlin2010-05-312-41/+131
| | | | Regenerate PNG
* [docs] Add an overview pageJohan Dahlin2010-05-305-1/+467
| | | | | Add an overview page for the documentation with a simple diagram explaining the relationship between the main components.
* [girepository] Correct GI_IS_ENUM_INFO macroJohan Dahlin2010-05-301-1/+2
| | | | A GIEnumInfo represents either an enum or a set of flags
* [ginfo] Document enum and enum valuesJohan Dahlin2010-05-301-46/+117
| | | | Document GIEnumInfo and GIValueInfo
* [info] Fix-up prototype indentationJohan Dahlin2010-05-301-6/+6
|
* [build] Remove gcov supportJohan Dahlin2010-05-287-120/+1
| | | | | It's been broken for some time, remove it instead of letting it bitrot.
* [doc] Document GIErrorDomainInfo methodsJohan Dahlin2010-05-281-3/+44
|
* [docs] Link to top of pagesJohan Dahlin2010-05-281-17/+17
|
* [GITypeInfo] Document and check typeJohan Dahlin2010-05-281-11/+160
| | | | Document GITypeInfo and check the info type in all functions.
* Remove leftover functionJohan Dahlin2010-05-281-3/+0
|
* [girepository] Check types function/callable/argJohan Dahlin2010-05-271-23/+128
| | | | | Check the info types for functions, callable and args. Verifies that the right type is sent in
* [girepository] Add macros for checking struct typeJohan Dahlin2010-05-271-1/+63
| | | | | Add macros for checking the sub-struct type. These are similar to the standard GObject macros.
* [docs] SignalInfo is a sub-struct of CallableInfoJohan Dahlin2010-05-271-1/+1
|
* [GIMarshallingTests] Fix incorrect array sizesColin Walters2010-05-271-7/+7
|
* Remove g_arg_info_is_dipper from documentationJohan Dahlin2010-05-271-1/+0
|
* Add type annotation for propertiesJohan Dahlin2010-05-274-0/+26
| | | | | | | | | | Add type annotation syntax for GObject properties. This makes it possible to override the type of a property. For instance, this will allow function pointers with a G_TYPE_POINTER type set to be used from a language binding which reads the typelib information in addition g_object_class_find_property. https://bugzilla.gnome.org/show_bug.cgi?id=618318
* [g-ir-generate] Write out array typeJohan Dahlin2010-05-273-2/+22
| | | | For GLib arrays, write out the array type to the tgir
* [scanner] Element-type annotation for GArray typesJohan Dahlin2010-05-275-4/+49
| | | | | | | Add support for (element-type) annotations for G*Array types. https://bugzilla.gnome.org/show_bug.cgi?id=619545
* [annotationparser] Avoid a couple of \Johan Dahlin2010-05-271-3/+3
|
* Remove g_arg_info_is_dipper from public APIColin Walters2010-05-261-1/+0
| | | | It wasn't useful, the new g_arg_info_is_caller_allocates is.
* [girparser] Don't hard require caller-allocates since it breaks parsingColin Walters2010-05-261-8/+3
| | | | | | We need to support parsing older .girs for inclusion purposes. (But we should probably have an explicit .gir version, and require the attribute for newer versions)
* [common.mk] Add builddir,srcdir and top_srcdir/girJohan Dahlin2010-05-261-1/+4
| | | | | | | They are now required with the updated Makefile.introspection rules, as the path to cairo-1.0.gir is no longer absolute we will have to add the src manually as it's references when srcdir != builddir, for instance in make distcheck.
* [common.mk] Clean up, avoid excessive variablesJohan Dahlin2010-05-261-14/+19
| | | | | Just define the ones we need, that are actually used by the other makefiles.
* Support (out caller-allocates)Colin Walters2010-05-2618-195/+731
| | | | | | | | | | | | | | | | | | | | | People have wanted support for marking (out) on functions of the form: /** * clutter_color_from_pixel: * @pixel: A pixel * @color: (out): Color to initialize with value of @pixel */ void clutter_color_from_pixel (guint32 pixel, ClutterColor *color); Where the caller is supposed to have allocated the argument; the C function just initializes it. This patch adds support for this argument passing style to introspection. In this case, we see the (out), and notice that there's only a single indirection (*) on the argument, and assume that this means (out caller-allocates). https://bugzilla.gnome.org/show_bug.cgi?id=604749
* [scanner] Support unsigned long/short intAlan Knowles2010-05-251-0/+2
|
* [sourcescanner] Support for line numbers on SymbolAlan Knowles2010-05-254-54/+64
| | | | | Add line numbers to symbols, which can be useful in later stages of the scanner.
* [glib] Skip g_date_to_struct_tm as skipJohan Dahlin2010-05-251-0/+6
|
* [docs] Add a struct hierarchy pageJohan Dahlin2010-05-252-0/+45
|
* Post-release version bumpColin Walters2010-05-241-1/+1
|
* Add support for the 'foreign' annotation to g-i-scannerGOBJECT_INTROSPECTION_0_6_12Tomeu Vizoso2010-05-237-0/+32
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=619450
* Add GInitiallyUnknowned subclass to Everything for testing floating referencesTomeu Vizoso2010-05-223-0/+72
|
* [docs] Document GICallableInfo and GIArgInfoJohan Dahlin2010-05-212-22/+129
| | | | Make docs more consistent and also fix a couple of broken links
* remove unnecessary $(srcdir)s from Makefile.amDan Winship2010-05-201-10/+10
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=616425
* Makefile.introspection: use $^, simplifying non-srcdir buildsDan Winship2010-05-201-3/+3
| | | | | | | | | | | | | | | | | | | In the .gir-building rule, use "$^" to refer to the source files, since that automatically looks in both $(srcdir) and $(builddir). This is particularly important since certain generated files will be in $(builddir) when building from git, but in $(srcdir) when building from tarballs If you were previously prefixing $(srcdir) to the Foo_gir_FILES members by hand, you should stop now. (Also, removed the dependencies on $(INTROSPECTION_SCANNER) and $(INTROSPECTION_COMPILER) for the .gir/.typelib rules, since the scanner one was broken anyway, and we don't have that kind of dependency for other rules (eg, making .o files depend on /usr/bin/gcc).) https://bugzilla.gnome.org/show_bug.cgi?id=616425
* [girepository] Use g_sliceJohan Dahlin2010-05-204-13/+13
| | | | | | Use g_slice to allocate instead of g_new(x, 1); It uses a memory pool internally and should be faster, especially for GBaseInfo/GRealInfo, structs which are tiny.
* [docs] Make gtk-doc language consistent.Johan Dahlin2010-05-191-50/+63
| | | | | | Make the language we use in the gtk-doc comments more consistent. Add transfer annotation for all functions returning a struct and mention how they should be freed.
* [docs] Reorganize sectionsJohan Dahlin2010-05-191-25/+27
| | | | | | Mark macros as standard and a couple of structs as private. Remove multiple defintion of GITypelib to reduce gtk-doc spew.