summaryrefslogtreecommitdiff
Commit message (Collapse)AuthorAgeFilesLines
* Release 0.9.6GOBJECT_INTROSPECTION_0_9_6Colin Walters2010-09-141-1/+1
|
* scanner: Add c_type for callbacksColin Walters2010-09-144-2/+29
| | | | | | | We weren't doing this consistently, which broke nsname != cprefix cases. https://bugzilla.gnome.org/show_bug.cgi?id=629683
* tests: Don't build regress if we don't HAVE_CAIROColin Walters2010-09-141-1/+6
| | | | https://bugzilla.gnome.org/show_bug.cgi?id=629359
* typelib compiler: Passthrough <doc> at any pointColin Walters2010-09-141-1/+1
| | | | This should have been in the previous commit.
* scanner: Parse annotations for typedefsColin Walters2010-09-145-1/+33
| | | | | | | | * Explicitly check for ast.Alias in annotation pass * Add "generic" attribs handling for aliases like docs, introspectable=0 etc. https://bugzilla.gnome.org/show_bug.cgi?id=629668
* scanner: Handle G_TYPE_HASH_TABLEColin Walters2010-09-144-6/+48
| | | | | Our Type creation from GType names didn't know how to handle the GObject boxeds for GHashTable, GArray etc.
* scanner: Consistently use ctype for documentation blocksColin Walters2010-09-132-12/+23
| | | | | | | | The "c_name" is really a fallback; use "ctype" if available which matches the C structure name. This fixes scanning at least TelepathyGLib where the namespace is different from the C prefix "Tp".
* scanner: Add a test for G_TYPE_ARRAY and (element-type uint)Colin Walters2010-09-132-0/+41
| | | | Similar to TelepathyGlib.
* scanner: Add GType for GVariantColin Walters2010-09-131-5/+10
| | | | This needs a manual override since GVariant is a fundamental.
* scanner: Bomb out more obviously if a namespace contains class name = namespaceColin Walters2010-09-131-0/+6
| | | | | If you pass --namespace=FooBar, and have a GObject named FooBar, we'd assert. Give the user an obvious error message.
* Annotate g_variant_builder_endTomeu Vizoso2010-09-131-0/+5
|
* Add a few notes to HACKINGJohan Dahlin2010-09-131-0/+7
|
* [test] Fix a leftover renameJohan Dahlin2010-09-131-1/+1
| | | | The gir name got renamed, update the rules to reflect that
* [test] Add typelib/girs to CLEANFILESJohan Dahlin2010-09-131-2/+7
| | | | So they are removed during uninstall
* [test] Use INTROSPECTION_SCANNERJohan Dahlin2010-09-131-1/+1
| | | | Since it sets the PYTHONPATH properly
* Do not use install-data-localJohan Dahlin2010-09-132-9/+10
| | | | Instead use xxxdir + xxx_DATA which uninstalls correctly
* Do not require .git to be presentJohan Dahlin2010-09-131-4/+4
| | | | | If .git is not present, do not require the pre-commit hook to be present either
* [tests] Add to EXTRA_DISTJohan Dahlin2010-09-131-1/+1
|
* [tests] Remove left over variableJohan Dahlin2010-09-131-1/+1
| | | | So make dist passes again
* Add annotation for g_variant_get_stringTomeu Vizoso2010-09-111-0/+6
|
* scanner: Readd support for --strip-prefixColin Walters2010-09-101-2/+3
| | | | | | We still really do want people to port to --identifier-prefix (and --symbol-prefix if necessary) because there's no ambiguity. Before the way we were casefolding was just a terrible mess.
* scanner: Allow gstreamer's GParamSpecMiniObject throughColin Walters2010-09-101-0/+13
| | | | | | | | It's wrong, but they can't change it now, so work around it here. https://bugzilla.gnome.org/show_bug.cgi?id=550616 https://bugzilla.gnome.org/show_bug.cgi?id=629306
* build: Also use $DESTDIR for regress.[ch]Colin Walters2010-09-101-1/+1
|
* build: Use $DESTDIR in install-data-localColin Walters2010-09-091-1/+1
|
* gio-2.0.c: Add more annotations for GVolume and GVolumeMonitorOwen W. Taylor2010-09-091-0/+43
| | | | Add annotations fixing warnings in in GVolume and GVolumeMonitor
* build: Update EXTRA_DIST, fix random stray + in MakefileColin Walters2010-09-091-2/+2
|
* gio: annotate g_volume_get_driveColin Walters2010-09-091-0/+6
|
* scanner: Skip functions with leading '_'Colin Walters2010-09-092-0/+5
| | | | | Multiple modules have '_' prefixed symbols in "public" headers meaning "don't use this in your app".
* scanner: Mark '_'-prefixed fields as introspectable=0Colin Walters2010-09-093-0/+34
| | | | | Typically these contain reserved callbacks; in any case we take a leading underscore to mean 'private'.
* Foreign structs can have constructorsTomeu Vizoso2010-09-094-2/+15
|
* gio: Annotate a few more functionsColin Walters2010-09-091-0/+12
|
* Use Node.ctype instead of Node.c_name when looking up comment blocksTomeu Vizoso2010-09-091-1/+4
| | | | | We were missing some annotation blocks for structs in typelibs with a name different to the C prefix.
* gio: Annotate g_mount_get_driveColin Walters2010-09-091-0/+6
|
* scanner: Unify parsing of compoundsColin Walters2010-09-091-38/+23
| | | | Avoids duplicate code.
* scanner: Fix style for previous commitColin Walters2010-09-091-3/+4
|
* gio: annotate g_mount_get_volumeColin Walters2010-09-091-0/+6
|
* Print helpful error message if --strip-prefix option is used.Saikiran Madugula2010-09-091-0/+7
|
* scanner: Kill glibastColin Walters2010-09-0810-416/+357
| | | | | | | | | | | | It was a stupid abstraction split, we only support GObject. * Clean up how we handle c:type - we only set it if we've actually seen a corresponding structure. * Add a warning if we don't see the structure typedef for an interface, since that's pretty bogus. (And fix regress.h to have one) * Rename the "type_name" attribute internally to "gtype_name" for clarity.
* scanner: Don't mark as constructors things that are more obviously methodsColin Walters2010-09-084-3/+82
| | | | | If the first parameter matches the origin, don't scan as a constructor. Happened in practice with meta_screen_append_new_workspace from mutter.
* scanner: Fix object hierarchy traversal in constructor scanningColin Walters2010-09-081-2/+2
| | | | We weren't properly hitting GObject.
* scanner: Don't attempt to pair methods/constructors with foreign namespacesColin Walters2010-09-083-0/+19
| | | | See test case, hit in practice in gnome-shell.
* Add missing annotationsFlorian Müllner2010-09-081-0/+17
| | | | Add some more (transfer full) annotations left out in commit cd0de25.
* Handle casing better for constantsOwen W. Taylor2010-09-076-15/+32
| | | | | | | | | | | | | | | | | Instead of handling constants by lower-casing them, stripping the lower-case prefix and upper-casing them again, leave them in the original case and check against upper-cased versions of namespace.symbol_prefixes. Wwe detect what version to test against by looking at the first character of the identifier, so we assume that --symbol-prefix options are always in lowercase. If that needs to be relaxed, then we'll have to check all symbols against both sets of prefixes. Add tests for constants to Regress.h and fix tests/warn/unresolved-type.h for a warning message that improved with this change. https://bugzilla.gnome.org/show_bug.cgi?id=629007
* Add missing annotations to GLib and GioOwen W. Taylor2010-09-072-0/+109
| | | | | Add (transfer full) and (array zero-terminated=1) to various GLib and Gio functions.
* scanner: Automatically skip callables which contain a skipped nodeColin Walters2010-09-073-0/+65
| | | | | For legacy library author convenience, propagate (skip) on e.g. structures to all callables which use them.
* [girepository] Add a missing includeJohan Dahlin2010-09-071-0/+1
|
* tests: Update expected gir for previous commitsColin Walters2010-09-072-32/+40
|
* Go back to previously handling of static methods on non-GObjectsOwen W. Taylor2010-09-072-2/+10
| | | | | | | | | | | | | Previous to the scanner rewrite, static methods were only handled for GObject subclasses. Go back to that for full compatibility with existing bindings and code. See bug 572408 for the topic of changing the API. The code for writing out static methods for records and boxed is left as future proofing, and the same handling is added for interfaces. https://bugzilla.gnome.org/show_bug.cgi?id=628967
* trick scanner into marking a symbol as a function instead of a methodJohn (J5) Palmieri2010-09-072-3/+3
|
* scanner: Fall back to searching all includes when uncertainColin Walters2010-09-071-1/+14
| | | | | | | | The scanner by default tries hard to ensure that we know immediately from seeing an identifier "FooBarBaz" that the namespace is "Foo". But libraries using --accept-unprefixed here screws this over. Potentially we could add --unstripped-identifier-prefix, but it's ugly. The best long term fix is to fix the namespacing in the library.