summaryrefslogtreecommitdiff
path: root/packages/gce-disk-expand/packaging/setup_rpm.sh
diff options
context:
space:
mode:
authorLiam Hopkins <liamh@google.com>2018-12-14 12:44:47 -0800
committerGitHub <noreply@github.com>2018-12-14 12:44:47 -0800
commitf773905cc0a70927c7180dd60d939fbf21264c92 (patch)
treea8aa77f094f896d6689fcee711eb490822b6b1f0 /packages/gce-disk-expand/packaging/setup_rpm.sh
parent091c4251a0d5e4af7c006af747251af7d7bcee62 (diff)
downloadgoogle-compute-image-packages-f773905cc0a70927c7180dd60d939fbf21264c92.tar.gz
Repo layout changes (#688)
Diffstat (limited to 'packages/gce-disk-expand/packaging/setup_rpm.sh')
-rwxr-xr-xpackages/gce-disk-expand/packaging/setup_rpm.sh35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/gce-disk-expand/packaging/setup_rpm.sh b/packages/gce-disk-expand/packaging/setup_rpm.sh
new file mode 100755
index 0000000..52f6a36
--- /dev/null
+++ b/packages/gce-disk-expand/packaging/setup_rpm.sh
@@ -0,0 +1,35 @@
+#!/bin/bash
+# Copyright 2018 Google Inc. All Rights Reserved.
+#
+# Licensed under the Apache License, Version 2.0 (the "License");
+# you may not use this file except in compliance with the License.
+# You may obtain a copy of the License at
+#
+# http://www.apache.org/licenses/LICENSE-2.0
+#
+# Unless required by applicable law or agreed to in writing, software
+# distributed under the License is distributed on an "AS IS" BASIS,
+# WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
+# See the License for the specific language governing permissions and
+# limitations under the License.
+
+NAME="gce-disk-expand"
+VERSION="2.0.0"
+
+rpm_working_dir=/tmp/rpmpackage/
+working_dir=${PWD}
+if [[ $(basename "$working_dir") != $NAME ]]; then
+ echo "Packaging scripts must be run from top of package dir."
+ exit 1
+fi
+
+# RPM creation tools.
+sudo yum -y install rpmdevtools
+
+rm -rf ${rpm_working_dir}
+mkdir -p ${rpm_working_dir}/{SOURCES,SPECS}
+cp packaging/${NAME}.spec ${rpm_working_dir}/SPECS/
+
+tar czvf ${rpm_working_dir}/SOURCES/${NAME}_${VERSION}.orig.tar.gz --exclude .git --exclude packaging --transform "s/^\./${NAME}-${VERSION}/" .
+
+rpmbuild --define "_topdir ${rpm_working_dir}/" -ba ${rpm_working_dir}/SPECS/${NAME}.spec