summaryrefslogtreecommitdiff
path: root/packages/google-compute-engine-oslogin
diff options
context:
space:
mode:
authorLiam Hopkins <liamh@google.com>2018-12-26 17:42:29 -0800
committerGitHub <noreply@github.com>2018-12-26 17:42:29 -0800
commit200053b345cd43c63020d1d1ac11d8460c5b4e98 (patch)
tree9dfd27400407eb7a6f59d10038131fbab548c09d /packages/google-compute-engine-oslogin
parent0b5162027a8a0eabcf8d5f4d8ccd18d2e7336fd6 (diff)
downloadgoogle-compute-image-packages-200053b345cd43c63020d1d1ac11d8460c5b4e98.tar.gz
Update libnss paths for OS Login (#721)
Diffstat (limited to 'packages/google-compute-engine-oslogin')
-rw-r--r--packages/google-compute-engine-oslogin/Makefile4
-rw-r--r--packages/google-compute-engine-oslogin/packaging/debian/control2
-rw-r--r--packages/google-compute-engine-oslogin/packaging/debian/google-compute-engine-oslogin.links2
-rwxr-xr-xpackages/google-compute-engine-oslogin/packaging/debian/rules4
4 files changed, 8 insertions, 4 deletions
diff --git a/packages/google-compute-engine-oslogin/Makefile b/packages/google-compute-engine-oslogin/Makefile
index c838166..ad02113 100644
--- a/packages/google-compute-engine-oslogin/Makefile
+++ b/packages/google-compute-engine-oslogin/Makefile
@@ -136,6 +136,10 @@ install: $(NSS_LIBRARY_NAME) $(LIBNSS_OSLOGIN_CACHE_NAME) $(PAM_ADMIN_MOD) $(PAM
install -m 0755 $(AUTHKEYS_BIN) $(DESTDIR)$(PREFIX)/$(AUTHKEYS_INSTALL_PATH)
install -m 0755 $(OSLOGIN_HELPER) $(DESTDIR)$(PREFIX)/$(BIN_INSTALL_PATH)
install -m 0755 $(NSS_CACHE_BIN) $(DESTDIR)$(PREFIX)/$(BIN_INSTALL_PATH)
+ifdef MAKE_LINKS
+ ln -sf $(LIBNSS_CACHE_OSLOGIN_NAME) $(DESTDIR)$(PREFIX)/$(NSS_INSTALL_PATH)/$(LIBNSS_CACHE_OSLOGIN_SONAME)
+ ln -sf $(NSS_LIBRARY_NAME) $(DESTDIR)$(PREFIX)/$(NSS_INSTALL_PATH)/$(NSS_LIBRARY_SONAME)
+endif
ifdef INSTALL_SELINUX
mkdir -p $(DESTDIR)$(PREFIX)/$(SELINUX_INSTALL_PATH)
install -T -m 0644 $(SELINUX_MODULE) $(DESTDIR)$(PREFIX)/$(SELINUX_INSTALL_PATH)/$(SELINUX_INSTALL_NAME)
diff --git a/packages/google-compute-engine-oslogin/packaging/debian/control b/packages/google-compute-engine-oslogin/packaging/debian/control
index a8d0064..ac14124 100644
--- a/packages/google-compute-engine-oslogin/packaging/debian/control
+++ b/packages/google-compute-engine-oslogin/packaging/debian/control
@@ -2,7 +2,7 @@ Source: google-compute-engine-oslogin
Maintainer: Google Cloud Team <gc-team@google.com>
Section: misc
Priority: optional
-Standards-Version: 3.9.6.1
+Standards-Version: 3.9.8
Build-Depends: debhelper (>= 9), libcurl4-openssl-dev, libjson-c-dev | libjson0-dev, libpam-dev
Package: google-compute-engine-oslogin
diff --git a/packages/google-compute-engine-oslogin/packaging/debian/google-compute-engine-oslogin.links b/packages/google-compute-engine-oslogin/packaging/debian/google-compute-engine-oslogin.links
deleted file mode 100644
index fd75bc5..0000000
--- a/packages/google-compute-engine-oslogin/packaging/debian/google-compute-engine-oslogin.links
+++ /dev/null
@@ -1,2 +0,0 @@
-/lib/libnss_google-compute-engine-oslogin-1.3.2.so /lib/libnss_oslogin.so.2
-/lib/libnss_cache_google-compute-engine-oslogin-1.3.2.so /lib/libnss_cache_oslogin.so.2
diff --git a/packages/google-compute-engine-oslogin/packaging/debian/rules b/packages/google-compute-engine-oslogin/packaging/debian/rules
index 65b1f4b..aa0f238 100755
--- a/packages/google-compute-engine-oslogin/packaging/debian/rules
+++ b/packages/google-compute-engine-oslogin/packaging/debian/rules
@@ -3,4 +3,6 @@
dh $@
override_dh_auto_install:
- dh_auto_install -- PAM_INSTALL_PATH=/lib/x86_64-linux-gnu/security BIN_INSTALL_PATH=/usr/bin
+ dh_auto_install -- PAM_INSTALL_PATH=/lib/$(DEB_HOST_MULTIARCH)/security \
+ BIN_INSTALL_PATH=/usr/bin NSS_INSTALL_PATH=/lib/$(DEB_HOST_MULTIARCH)/ \
+ MAKE_LINKS=true