summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am16
1 files changed, 12 insertions, 4 deletions
diff --git a/Makefile.am b/Makefile.am
index 0c1a802..adc21d7 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,10 +7,6 @@ EXTRA_DIST =
# included in the 'subdirs' variable.
SUBDIRS = $(subdirs)
-# Scripts and utilities to be installed by 'make install'.
-dist_bin_SCRIPTS = scripts/gmock_doctor.py
-bin_SCRIPTS = scripts/gmock-config
-
# This is generated by the configure script, so clean it for distribution.
DISTCLEANFILES = scripts/gmock-config
@@ -199,3 +195,15 @@ maintainer-clean-local:
# Death tests may produce core dumps in the build directory. In case
# this happens, clean them to keep distcleancheck happy.
CLEANFILES = core
+
+# Disables 'make install' as installing a compiled version of Google
+# Mock can lead to undefined behavior due to violation of the
+# One-Definition Rule.
+
+install-exec-local:
+ echo "'make install' is dangerous and not supported. Instead, see README for how to integrate Google Mock into your build system."
+ false
+
+install-data-local:
+ echo "'make install' is dangerous and not supported. Instead, see README for how to integrate Google Mock into your build system."
+ false