summaryrefslogtreecommitdiff
path: root/lib/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'lib/configure.ac')
-rw-r--r--lib/configure.ac44
1 files changed, 44 insertions, 0 deletions
diff --git a/lib/configure.ac b/lib/configure.ac
new file mode 100644
index 0000000..72f2c6a
--- /dev/null
+++ b/lib/configure.ac
@@ -0,0 +1,44 @@
+dnl autoconf configuration for gperf/lib
+
+dnl Copyright (C) 1998, 2002, 2005 Free Software Foundation, Inc.
+dnl Written by Douglas C. Schmidt <schmidt@ics.uci.edu>
+dnl and Bruno Haible <bruno@clisp.org>.
+dnl
+dnl This file is part of GNU GPERF.
+dnl
+dnl GNU GPERF is free software; you can redistribute it and/or modify
+dnl it under the terms of the GNU General Public License as published by
+dnl the Free Software Foundation; either version 2, or (at your option)
+dnl any later version.
+dnl
+dnl GNU GPERF is distributed in the hope that it will be useful,
+dnl but WITHOUT ANY WARRANTY; without even the implied warranty of
+dnl MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+dnl GNU General Public License for more details.
+dnl
+dnl You should have received a copy of the GNU General Public License
+dnl along with this program; see the file COPYING.
+dnl If not, write to the Free Software Foundation, Inc.,
+dnl 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301, USA. */
+
+AC_INIT(hash.cc)
+AC_PROG_MAKE_SET
+dnl
+dnl checks for programs
+dnl
+AC_PROG_CC
+ dnl sets variable CC
+AC_PROG_CPP
+ dnl sets variable CPP
+AC_PROG_CXX
+ dnl sets variable CXX
+AC_PROG_CXXCPP
+ dnl sets variable CXXCPP
+AC_PROG_RANLIB
+ dnl sets variable RANLIB
+CL_PROG_INSTALL
+ dnl sets variables INSTALL, INSTALL_DATA, INSTALL_PROGRAM
+dnl
+dnl That's it.
+dnl
+AC_OUTPUT(Makefile)