summaryrefslogtreecommitdiff
path: root/src/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'src/configure.ac')
-rw-r--r--src/configure.ac20
1 files changed, 10 insertions, 10 deletions
diff --git a/src/configure.ac b/src/configure.ac
index 1f05feb..33f4983 100644
--- a/src/configure.ac
+++ b/src/configure.ac
@@ -1,6 +1,6 @@
dnl autoconf configuration for gperf/src
-dnl Copyright (C) 1998, 2000, 2002-2003, 2007 Free Software Foundation, Inc.
+dnl Copyright (C) 1998, 2000, 2002-2003, 2007, 2009 Free Software Foundation, Inc.
dnl Written by Douglas C. Schmidt <schmidt@ics.uci.edu>
dnl and Bruno Haible <bruno@clisp.org>.
dnl
@@ -20,8 +20,8 @@ dnl You should have received a copy of the GNU General Public License
dnl along with this program. If not, see <http://www.gnu.org/licenses/>.
AC_PREREQ([2.60])
-AC_INIT(main.cc)
-AC_CONFIG_HEADER(config.h)
+AC_INIT([main.cc])
+AC_CONFIG_HEADER([config.h])
AC_PROG_MAKE_SET
dnl
dnl checks for programs
@@ -40,16 +40,16 @@ dnl
dnl checks for compiler characteristics
dnl
AC_MSG_CHECKING([for stack-allocated variable-size arrays])
-AC_CACHE_VAL(gp_cv_cxx_dynamic_array, [
+AC_CACHE_VAL([gp_cv_cxx_dynamic_array], [
AC_LANG_SAVE()
AC_LANG_CPLUSPLUS()
AC_TRY_COMPILE([int func (int n) { int dynamic_array[n]; }], [],
-gp_cv_cxx_dynamic_array=yes, gp_cv_cxx_dynamic_array=no)
+ [gp_cv_cxx_dynamic_array=yes], [gp_cv_cxx_dynamic_array=no])
AC_LANG_RESTORE()
])
-AC_MSG_RESULT($gp_cv_cxx_dynamic_array)
+AC_MSG_RESULT([$gp_cv_cxx_dynamic_array])
if test $gp_cv_cxx_dynamic_array = yes; then
- AC_DEFINE(HAVE_DYNAMIC_ARRAY, 1,
+ AC_DEFINE([HAVE_DYNAMIC_ARRAY], [1],
[Define if the C++ compiler supports stack-allocated variable-size arrays.])
fi
dnl
@@ -58,9 +58,9 @@ dnl
dnl
dnl checks for libraries
dnl
-AC_CHECK_LIB(m, rand, GPERF_LIBM="-lm", GPERF_LIBM="")
-AC_SUBST(GPERF_LIBM)
+AC_CHECK_LIB([m], [rand], [GPERF_LIBM="-lm"], [GPERF_LIBM=""])
+AC_SUBST([GPERF_LIBM])
dnl
dnl That's it.
dnl
-AC_OUTPUT(Makefile)
+AC_OUTPUT([Makefile])