summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2010-04-26 14:05:05 -0400
committerEric S. Raymond <esr@thyrsus.com>2010-04-26 14:05:05 -0400
commitcd6db468079343be72df7f74f6b6e778048a2a4d (patch)
treef4e08a9d91f26f76f80cd6a8654be0424366d8e3 /Makefile.am
parent555aa57e58147b231ec45cee63dfaa72e6f36ea6 (diff)
downloadgpsd-cd6db468079343be72df7f74f6b6e778048a2a4d.tar.gz
Simplify the test productions for udev.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 2 insertions, 7 deletions
diff --git a/Makefile.am b/Makefile.am
index 6c096a21..04045285 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -785,19 +785,14 @@ endif
# another window, then run 'make udev-test', then plug and unplug the
# GPS ad libitum. All is well when you get fix reports each time a GPS
# is plugged in.
-#
-# Note: We copy gpsd.rules to two places rather than symlinking in order
-# to avoid confusing inotify, which Ubuntu uses to track changes.
udev-install:
- cp $(srcdir)/gpsd.rules /lib/udev/
cp $(srcdir)/gpsd.rules /lib/udev/rules.d/025_gpsd.rules
- cp $(srcdir)/gpsd.hotplug /lib/udev/
- cp $(srcdir)/gpsd.hotplug.wrapper /lib/udev/
+ cp $(srcdir)/gpsd.hotplug $(srcdir)/gpsd.hotplug.wrapper /lib/udev/
chmod a+x /lib/udev/gpsd.hotplug /lib/udev/gpsd.hotplug.wrapper
udev-uninstall:
- rm -f /lib/udev/{gpsd.rules,gpsd.hotplug,gpsd.hotplug.wrapper}
+ rm -f /lib/udev/{gpsd.hotplug,gpsd.hotplug.wrapper}
rm -f /lib/udev/rules.d/025_gpsd.rules
udev-test: