summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorChris Kuethe <chris.kuethe@gmail.com>2006-05-09 21:43:53 +0000
committerChris Kuethe <chris.kuethe@gmail.com>2006-05-09 21:43:53 +0000
commitccf83f71299b625328d2ee5303ed9274761fe31c (patch)
tree45ccbd6a319cea4a7d3abe6095a0ba796c8bea74 /configure.ac
parent0af8a52b5d6157ca2d16626c1a1535717db6f437 (diff)
downloadgpsd-ccf83f71299b625328d2ee5303ed9274761fe31c.tar.gz
Support fixed-speed operation.
Taking an item from esr's wish list, this patch locks gpsd to a particular serial port speed at compile time. This should make life a little easier on embedded users who don't want to go hunting for the baud rate at startup all the time when they know where/what baud the GPS is. This patch is not very well tested yet - it went to gpsd-dev and I heard no complaints - but I am committing it so it gets more testing.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index eed83951..3db909c9 100644
--- a/configure.ac
+++ b/configure.ac
@@ -320,6 +320,20 @@ else
AC_MSG_RESULT([no])
fi
+dnl check for port speed fixed at compile-time
+AC_ARG_ENABLE(fixed-port-speed,
+ AC_HELP_STRING([--enable-fixed-port-speed],
+ [compile with fixed serial port speed]),
+ [ac_baud=$enableval], [ac_baud=no])
+AC_MSG_CHECKING([for fixed port speed])
+if test x"$ac_baud" != "xno"; then
+ AC_MSG_RESULT([$ac_baud])
+ AC_DEFINE_UNQUOTED([FIXED_PORT_SPEED], $ac_baud, [Fixed port speed])
+ FIXED_PORT_SPEED="-DSPEEDFLAGS=$ac_baud"
+else
+ AC_MSG_RESULT([no])
+fi
+
dnl Manually configure DBUS until we figure out a
dnl distro-independent was to check for both libraries and headers
AC_ARG_ENABLE(dbus,
@@ -395,6 +409,7 @@ echo "Evermore : $ac_evermore"
echo "RTCM104 support : $ac_rtcm104"
echo "NTP SHM : $ac_ntpshm"
echo "NTP PPS : $ac_pps"
+echo "Fixed port speed : $ac_baud"
echo "Enable shared libraries : $enable_shared"
echo "Enable DBUS support : $ac_dbus"
echo "------------------------------------------"