summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorEric S. Raymond <esr@thyrsus.com>2005-08-17 15:58:29 +0000
committerEric S. Raymond <esr@thyrsus.com>2005-08-17 15:58:29 +0000
commitd364454d4f01ba201dec1bf751bf9d809fac1e2b (patch)
treec9fd1b63e40f20ccf161549ecf7dcfd08b448118 /configure.ac
parent06b551513c04a620cef0f51cfa63369c54b51bfa (diff)
downloadgpsd-d364454d4f01ba201dec1bf751bf9d809fac1e2b.tar.gz
Belgabor's fix for DBUD configuration.
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 4 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index d3834fc5..de4dce10 100644
--- a/configure.ac
+++ b/configure.ac
@@ -329,9 +329,12 @@ if test x"$ac_dbus" == "xyes"; then
AC_MSG_RESULT([yes])
AC_DEFINE([DBUS_ENABLE], 1, [DBUS support])
# Older versions of atotools barf and die on this.
- #PKG_CHECK_MODULES(DBUS, dbus-1 >= 0.23.4 )
+ PKG_CHECK_MODULES(DBUS, dbus-1 >= 0.23.4 )
AC_SUBST(DBUS_CFLAGS)
AC_SUBST(DBUS_LIBS)
+ PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1 >= 0.22 )
+ AC_SUBST(DBUS_GLIB_CFLAGS)
+ AC_SUBST(DBUS_GLIB_LIBS)
else
AC_MSG_RESULT([no])
fi