summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac8
1 files changed, 8 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 0f06361e..557faa96 100644
--- a/configure.ac
+++ b/configure.ac
@@ -79,6 +79,14 @@ AH_VERBATIM([_GNU_SOURCE],
# define UNUSED __attribute__((unused)) /* Flag variable as unused */
#else /* not __GNUC__ */
# define UNUSED
+#endif
+
+/* Some libc's don't have strlcat/strlcpy. Local copies are provided */
+#ifndef HAVE_STRLCAT
+size_t strlcat(/*@out@*/char *dst, /*@in@*/const char *src, size_t size);
+#endif
+#ifndef HAVE_STRLCPY
+size_t strlcpy(/*@out@*/char *dst, /*@in@*/const char *src, size_t size);
#endif])
dnl Check for X libraries