summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorwlemb <wlemb>2000-03-14 17:16:53 +0000
committerwlemb <wlemb>2000-03-14 17:16:53 +0000
commit2caab1fcae67f1de5d5dd36b053bc9997104c68d (patch)
tree28939ff3baef868765295132c7805066871be67b /configure.in
parent82c3453c11ce746757f528ab2527429794392346 (diff)
downloadgroff-2caab1fcae67f1de5d5dd36b053bc9997104c68d.tar.gz
* configure.in: Added test for strdup.
* src/devices/grolbp/lbp.cc: Added a strdup() version in case none is available. Replaced dynamic allocation of arrays `[...]' with `new' operator. Other minor fixes.
Diffstat (limited to 'configure.in')
-rwxr-xr-xconfigure.in2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 4f88ab60..721fd4c8 100755
--- a/configure.in
+++ b/configure.in
@@ -39,7 +39,7 @@ saved_libs="$LIBS"
LIBS="$LIBS -lc $LIBM"
AC_REPLACE_FUNCS(fmod strtol getcwd strerror putenv)
LIBS="$saved_libs"
-AC_CHECK_FUNCS(rename mkstemp strcasecmp strsep)
+AC_CHECK_FUNCS(rename mkstemp strcasecmp strsep strdup)
AC_DECL_SYS_SIGLIST
dnl checks for compiler characteristics
GROFF_ARRAY_DELETE