summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac5
1 files changed, 3 insertions, 2 deletions
diff --git a/configure.ac b/configure.ac
index c5079633..e4d0d6ae 100644
--- a/configure.ac
+++ b/configure.ac
@@ -51,15 +51,16 @@ GROFF_TIME_T
AC_TYPE_SIGNAL
GROFF_STRUCT_EXCEPTION
dnl checks for libraries
+GROFF_LIBC
GROFF_LIBM
dnl checks for functions
AC_FUNC_MMAP
saved_libs="$LIBS"
-LIBS="$LIBS -lc $LIBM"
+LIBS="$LIBS $LIBC $LIBM"
AC_REPLACE_FUNCS(fmod getcwd putenv snprintf strcasecmp \
strerror strncasecmp strtol)
LIBS="$saved_libs"
-AC_CHECK_FUNCS(gettimeofday isatty rename setlocale strsep)
+AC_CHECK_FUNCS(gettimeofday isatty kill rename setlocale strsep)
GROFF_MKSTEMP
AC_DECL_SYS_SIGLIST
dnl checks for compiler characteristics