summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorEdward Hervey <edward@collabora.com>2014-08-01 10:41:28 +0200
committerEdward Hervey <edward@collabora.com>2014-08-01 10:41:28 +0200
commitc57c5f6a8f0cd4a88cfbe77edfbc21a17551ec5a (patch)
tree8b508d63dc3f9691acae178e2d5b82423505c2e1 /Makefile.am
parentcbbb7c1e3d6b14302e28813e8466291bbc92e07c (diff)
downloadgst-libav-c57c5f6a8f0cd4a88cfbe77edfbc21a17551ec5a.tar.gz
Makefile: Add usage of build-checks step
Allows building checks without running them
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am8
1 files changed, 8 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index b843d30..5c62203 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -22,6 +22,14 @@ check-valgrind:
check-torture:
@true
+if HAVE_GST_CHECK
+build-checks:
+ cd tests/check && make build-checks
+else
+build-checks:
+ true
+endif
+
CRUFT_FILES = \
$(top_builddir)/common/shave \
$(top_builddir)/common/shave-libtool \