summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorThibault Saunier <thibault.saunier@osg.samsung.com>2016-09-30 11:35:41 -0300
committerThibault Saunier <thibault.saunier@osg.samsung.com>2016-09-30 11:38:37 -0300
commiteff2c8be16e760b430355239e5892910dd3ced80 (patch)
tree2588d81f2a393be0436dcfdf696e13623ecaf2a1 /meson.build
parent4a9a7d61e56820a108aa78409d216d65e59ee0e3 (diff)
downloadgst-libav-eff2c8be16e760b430355239e5892910dd3ced80.tar.gz
meson: Setup pre-commit hooks when configuring
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build3
1 files changed, 3 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 2d335b6..9441d78 100644
--- a/meson.build
+++ b/meson.build
@@ -57,3 +57,6 @@ gst_libav_args = ['-DHAVE_CONFIG_H', '-Wno-deprecated-declarations']
configinc = include_directories('.')
plugins_install_dir = '@0@/gstreamer-1.0'.format(get_option('libdir'))
subdir('ext/libav/')
+
+python3 = find_program('python3')
+run_command(python3, '-c', 'import shutil; shutil.copy("hooks/pre-commit.hook", ".git/hooks/pre-commit")')