summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorGuillaume Desmottes <guillaume.desmottes@collabora.co.uk>2017-05-22 11:23:33 +0200
committerNicolas Dufresne <nicolas.dufresne@collabora.com>2017-07-03 10:15:17 -0400
commit2be1214cab336f4d71b86c0763091c4a822ca0c2 (patch)
tree19e38a3340384cbc2b79f5582bf53554a25c40a6 /meson.build
parent65b3a2769de5a890463b98bf83fb60dba794e498 (diff)
downloadgst-omx-2be1214cab336f4d71b86c0763091c4a822ca0c2.tar.gz
add 'zynqultrascaleplus' as OMX target
Adding support for the 'Zynq UltraScale+' as a new OMX target. See https://www.xilinx.com/products/silicon-devices/soc/zynq-ultrascale-mpsoc.html for details about the platform. https://bugzilla.gnome.org/show_bug.cgi?id=783097
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build2
1 files changed, 2 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index d99d275..042bf60 100644
--- a/meson.build
+++ b/meson.build
@@ -233,6 +233,8 @@ elif omx_target == 'rpi'
endif
elif omx_target == 'bellagio'
cdata.set('USE_OMX_TARGET_BELLAGIO', 1)
+elif omx_target == 'zynqultrascaleplus'
+ cdata.set('USE_OMX_TARGET_ZYNQ_USCALE_PLUS', 1)
else
error ('Unsupported omx target specified. Use the -Dwith_omx_target option')
endif