summaryrefslogtreecommitdiff
path: root/meson.build
diff options
context:
space:
mode:
authorJulien Isorce <jisorce@oblong.com>2017-08-22 13:48:26 +0100
committerJulien Isorce <jisorce@oblong.com>2017-12-11 16:59:01 +0000
commit71ddf32df9a80cbf20e719fa144b8ed52e784eeb (patch)
treea2221a31711f134b4f645cd92e17e0a48b59c0e5 /meson.build
parentff74c66a9a5e0b78a22e8de470180f32ae01aa08 (diff)
downloadgst-omx-71ddf32df9a80cbf20e719fa144b8ed52e784eeb.tar.gz
example: port testegl.c to desktop
Will be easier to maintain. Also uniformize autotool build with meson build which is already retrieving the gl libs. https://bugzilla.gnome.org/show_bug.cgi?id=781606
Diffstat (limited to 'meson.build')
-rw-r--r--meson.build6
1 files changed, 6 insertions, 0 deletions
diff --git a/meson.build b/meson.build
index 1269614..c38d937 100644
--- a/meson.build
+++ b/meson.build
@@ -153,6 +153,8 @@ gstvideo_dep = dependency('gstreamer-video-1.0', version : gst_req,
gstgl_dep = dependency('gstreamer-gl-1.0', version : gst_req,
fallback : ['gst-plugins-bad', 'gstgl_dep'], required : false)
+x11_dep = dependency('x11', required : false)
+
if host_machine.system() != 'windows'
gstcheck_dep = dependency('gstreamer-check-1.0', version : gst_req,
fallback : ['gstreamer', 'gst_check_dep'])
@@ -293,6 +295,10 @@ if gstgl_dep.found()
cdata.set ('HAVE_GST_GL', 1)
endif
+if x11_dep.found()
+ cdata.set ('HAVE_X11', 1)
+endif
+
omx_struct_packing = get_option ('with_omx_struct_packing').to_int()
if omx_struct_packing == 0
omx_struct_packing = default_omx_struct_packing